Active-Directory plugin too undocumented

Issue #20 resolved
Daniel Jilg
created an issue


I'm trying to use scm-manager with the Active Directory plugin. I've installed it, but could not find any configuration options in the UI. Could you please give me some pointers where I should go next in order to get this to work?

So far I've done the following, on a freshly installed Windows 7 VM:

  • downloaded scm-manager, ran scm-server/bin/scm-server.bat to start the server
  • logged in, installed the active directory plugin
  • added the virtual machine's windows to our local domain
  • restarted the server
  • created a test git repository
  • tried to log into the repository using LocalUsername, DomainUsername and Domain\DomainUsername

none of those worked. Help me please?

Comments (7)

  1. Daniel Jilg reporter

    Hi, thanks for answering.

    Sadly, I'm not able to login as domain user. Which format should I use for the login?

    • Domain\DomainUser
    • or just DomainUser
  2. Daniel Jilg reporter

    It works! The difference is that I ran the server as a domain user instead of a local user.

    Here's my proposal for documenting this:

    How To: Active Directory Plugin

    The AD plugin requires that you run the scm-manager server on windows.

    • Connect your Windows machine to your local Active Directory
    • Log in as a user of that directory
    • Run the scm-server batch file
    • Install the active-directory plugin

    Thanks btw, scm-manager is great.

  3. Anonymous

    How can I login to a remote active directory? Should it work in same way?

    I'm not able to login. For instance if my domain is:

    My login will be example.comusername ? :S And how should I add to the users?

  4. Log in to comment