1. Sebastian Sebastian
  2. scm-manager

Issues

Issue #218 resolved

Double Authentication

Chad Beaudin
created an issue

We have a few Hg projects setup through SCM-Manager. They are forcing everyone to authenticate twice. While this is an inconvenience for the developers it is a stopper for some of our tools such as Jenkins and Crucible, as the tools fail to connect. Jenkins seems to be able to eventually connect, but polling for automated builds only works occasionally. Crucible can't connect at all.

I spent a few minutes searching issues and did not run across this. Do we have something misconfigured on our end?

Comments (16)

  1. Stephan Christann

    Hello Chad Beaudin,

    please give us some more information about your system and installation type (windows/linux/distro, with/without apache, SCM-Manager Version). Perhaps you can turn up logging level according to the scm manager faq in order to post some of your logs.

  2. Chad Beaudin reporter

    Sorry Stephan, I should have included some of that with my initial post.

    • Running SCM-Manager 1.17
    • Running on CentOS 6.2
    • Configured to use Crowd.

    I turned up logging (to TRACE), restarted the server, and am not getting anything in the log file. It is 0 size. That doesn't seem right does it?

  3. Stephan Christann

    I guess you restarted the app after rising the log level? Maybe this is caused by the crowd authentication. I did not use the crow daemon in the past. Are you trying so set up SSO authentication?

  4. Stephan Christann

    Hello Chad,

    I had a short chat with Sebastian, have you tried to authenticate with a user from the local db (e.g. scmadmin)? Does this issue change its behavior when using different user types? Anyway, we will need the trace log.

  5. Chad Beaudin reporter

    Correct, I restarted the scm service.

    SSO would be nice down the road. At the moment we are just trying to consolidate our user management through Crowd. Although our Crowd does back to AD.

    Setting up a test user in scm-manager seems to work fine. No double authentication. So it appears that the problem might be related to the Crowd integration?

  6. Stephan Christann

    Hello Chad,

    that was my presumption. Sebastian told me, that we will have to have the trace log, in oder to see where the problem is caused. If the logging does not work. please post which configuration files you edited for rising the log level with the full path and the exact change.

  7. Chad Beaudin reporter

    I've been messing around with the log more and can't get it to log anything.

    I change the scm-server/conf/logging.xml file.

    <logger name="sonia.scm" level="TRACE" />

    I also tried changing a few lines down. <root level="TRACE">

    Neither resulted in any change. The scm-manager/logs/scm-manager.log file is empty. It is getting touched, as the date changes to match the start time of the server, but there is nothing in the file.

  8. Stephan Christann

    One question was not answered. Do you use the .war installation, or are you using the version with the build in web application server? The log level is configured differently in the different versions of scm-manager.

  9. Chad Beaudin reporter

    I did not perform the install so I am not positive. I'm fairly certain it is the version with the built in web app server.

    It looks like there is a file scm-server-1.17-app.tar.gz next to the directory where scm-server is installed.

  10. Log in to comment