1. Sebastian Sebastian
  2. scm-manager
  3. Issues

Issues

Issue #228 resolved

Couldn't push to server, abort: authorization failed

Yun Sheng
created an issue

Everything worked fine on my internet access computer, then I run scm-server.bat on the server which don't have internet access, I copied .scm/config/hg.xml and .scm/pkg and .scm/plugins and .scm/lib and .scm/config/userrepo.xml to the server. everything worked well when I create a repo, clone a repo, but when I push a changeset to the repo, it said:

abort: authorization failed and returned with 255

I'm sure I didn't mess up with the password, and I was thinking it was because this repo was created by a user, so I tried to create a repo by the admin, but it still happens.

Thank you very much for helping me through this in such a fast speed.

Comments (12)

  1. Yun Sheng reporter

    Yes I can see the help of hg.

    btw, the path in the no internet access machine is: E:\Documents and Settings\Administrator\.scm\pkg\flea71\hg\2.1\bin\hg.bat

  2. Sebastian Sebastian repo owner

    In the log file you posted, i see the following path:

    C:\Documents and Settings\nzwqv9\.scm\pkg\f1ea71\hg\2.1\bin\hg.bat
    

    You have changed the path at "Config->Repository Types->Mercurial Settings" to the following?

    E:\Documents and Settings\Administrator\.scm\pkg\flea71\hg\2.1\bin\hg.bat
    

    If you have changed the path and you still get the same error, then please post a new log from the server.

  3. Log in to comment