Issue #239 resolved

Unable to set up Active directory authentication

Anonymous created an issue

Hello Friends,

After expending hours trying to setup ActiveDirectory authentication and googleing for some answer to my problem I decide ask you all for help.

Here is what is happening:

I did SCM installation by copying SCM-WAR file to my tomcat7 webapps folder on a Suse 11 Box. Everything works as expected. Tried to setup ActiveDirectory performing following tasks: From de Dropdown box Selected ActiveDirectory Provided Base DN, Connection DN, Connection password, Host URL, Enabled Authentication.

After clicking on Test Connection button I provide valid credentials in the popup dialog and accept. Although I provided a valid Host-URL I still receive following errors: Connection: FAILURE Search user: FAILURE Authenticate user: FAILURE Returned user is valid: FAILURE Exception: localhost:389

But the most important part is the exception showing localhost:389. The important part here is that no matter what host I provide it always tries to connect to localhost:389

Any Clue?

Thanks in advance Jose

Comments (8)

  1. Sebastian Sdorra repo owner

    After a short inspection of the sourcecode, i think it is a bug. The plugin does not take the settings from the form, it uses always the stored ones. A simple workaround is to save your settings before you test. But i will try to fix this.

  2. Jose Ortuno

    Hi Sebastian,

    Fist thanks for the quick responce. I do have a Bitbucket account I will try the workaround and look forward for the final resolution.

    Cheers,

    Jose

  3. Arun Sangal

    I tried this value for group - thanks.

    In my case, SCM-Manager - under General area, under Ldap Auth ..section,

    Profile: custom Fullname Attribute Name: cn ID Attribute Name: SAMAccountName Mail Attribute Name: mail Group Attribute Name: memberOf Base DN: DC=tsh,DC=mycompany,DC=com Connection DN: CN=First Last,OU=Employee Full-Time,OU=Corporate,DC=Company,DC=com Connection Password: Password_of_First Last_user_as_given_in_cn=value Host URL: ldap:xxx.xxx.xx.x:389 Search Filter: (&(SAMAccountName={0})(objectClass=user)) Search Scope: sub (one - didn't work for me). People Unit: Group Unit:

    left blank for last 2. Enabled nested ad groups, enabled "enable/disable ldap" last checkbox.

    Note: if i change scope from sub to one, it didnt work (may be i had to give values like you said for People/Group Unit fields). When I clicked/checked - Use StartTLS encryption - it didnt work.. otherwise, it works finally.

  4. Log in to comment