Upgrade 1.17->1.20: Session timeout all the time

Issue #249 resolved
Andreas Kaempf
created an issue

I run scm-manager 1.17 as user scm. For testing the latest release 1.20 I copied my config files to my root user and execute scm-server from there directly.

I can log in with scmadmin, but I get a session timeout instantly. After clicking OK and logging in again as scmadmin I get the timeout at once again and so on.

After clicking Abbrechen/Abort I can log out and log in again. Then I am not getting a session timeout but a white window with "failure" and an OK button.

What is necessary for a proper session timeout handling? Is there any new entry to the config files I am missing? Is there any description how to update from one version to the next?

I will not be able to use the latest release until this is not solved.

Thanks for your help!

Comments (8)

  1. Andreas Kaempf reporter

    The scm-server reports the following error:

    java.io.IOException: Server returned HTTP response code: 400 for URL: http://plugins.scm-manager.org/scm-plugin-backend/api/1.20/plugins?os=Linux&arch=64&snapshot=false

    Moreover, despite my proxy settings still present in the config file, it cannot download the plug-ins.

  2. Sebastian Sdorra repo owner

    I think the timeout problem comes from the browser cache. Could you try to clear the cache of your browser?

    And the response code 400 sound like a proxy problem. Have you checked Config->General for your proxy settings?

  3. Andreas Kaempf reporter

    So, I tried this with a different browser (IE) and with an erased browser cache (Firefox). The problem remains the same. I am still using the old version now until I have the possibility to fix it.

  4. Log in to comment