1. Sebastian Sebastian
  2. scm-manager

Issues

Issue #26 new

Git repository authentication with ssh-key

cmseconet
created an issue

I've tried several GUI-Tools and most of them fail to handle http authentication properly (ether they don't ask for the user/pass and fail silently, or they don't provide a way to save the credentials).

Therefore I would like to see authentication support with a ssh-key-file, if that's possible at all.

Any other suggestions?

Comments (21)

  1. Anonymous

    ssh public key authentication support in addition to ldap authentication would be just perfect. We often deploy projects via capistrano, so we need a way to authenticate without providing username and password...

  2. Anonymous

    The support of SSH keys can be probably implemented via the gitolite, when SCM Manager permissions can be transformed to gitolite.conf and pushed to gitolite-admin repo automatically on change.It would also require some code to handle public key uploading into gitolite keydir folder.

  3. Derick Qua

    +1 To Señor Anony Mouse: SCM Manager is the front-end I've been looking for to manage a menagerie of Git (and yes, some hg) repos. Fits in every way except no gitolite support. Wonder how long it would take to write up a plugin (if possible) to do so?

  4. Anonymous

    You can fix the crashes by deleting the plugins folder in your .scm folder. You'll have to reinstall and configure the plugins, but it SHOULD fix the server.

  5. TeChn4K

    SSH public key authentication will be a great feature ! For me, this is the last missing feature...

    scm-ssh-plugin is not working on 1.40. Does somebody have solution ?

    @Jelloeater Thanks, it works

  6. Alexander Kammerer

    I just tried installing version 1.0.0-release but it caused a 503 error. At least I know how to fix it without deleting the whole plugins/ directory.

    Just go to the home directory, search for com/aquenos and either delete the aquenos directory completely or search for the plugin itself.

    Seems like this plugin is not usable. Did anyone try and contact the author?

  7. Anonymous

    I did the "upgrade to new version"-steps. I renamed the old standalone (1.45). I downloaded 1.46 and placed it at the same directory as the old. Uninstalled service. Installed service. I did this on my Windows 8, before I am trying on the office build server with the Windows Server 2012.

  8. Log in to comment