Issue #27 resolved

Can't clone a Git repository shared on Windows

Anonymous created an issue


I'm trying your nice program on Windows. After importing a local repository (url http://localhost:8080/scm/git//d/git/git1/my_project/.git), i tried to clone this repository but it failed.

With Egit, I got the following message: " Cannot list the avalaible branches. Reason: http://localhost:8080/scm/git//d/git/git1/my_project/.git: http://localhost:8080/scm/git//d/git/git1/my_project/.git/info/refs/?service=git-upload-pack not found "

It thought he doesn't find the info directory as i got the following message with msysgit. " fatal: http://localhost:8080/scm/git//d/git/my_project/.git/info/refs not found: did you run git update-server-info on the server? "

Then i ran the git-update-server-info and got the same message with Egit and msysgit/

Does your program use jgit instead msysgit ? How can i configure the repository or your software to solve this issue ?

Best Regards,

Comments (7)

  1. Sebastian Sdorra repo owner

    What is the name of your repository? it is "/d/git/git1/my_project" or it is "my_project"? When the name is "my_project", then you should use this url http://localhost:8080/scm/git/my_project. Repositories can not have slashes in their names.

    Yes the scm-manager uses jgit.

    The simplest way to import a git repository with scm-manager is the following:

    • create a new repository with the webinterface (choose a simple name without additional characters)
    • then go to your local repository and push it to the new repository:

    git push http://localhost:8080/scm/git/yourrepositoryname master

    Here is simple video example for creating a new git repository:

  2. krazybug

    Hi Sebastian.

    I've got an account now. Indeed, the name of my repo is "/d/git/git1/my_project" because i've created it with msysgit and imported in scm-manager.

    I'll try you method and report you a status. Thanks

  3. krazybug

    I've got an issue with msysgit under XP and unicode during the push " warning: Your console font probably doesn't support Unicode. If you experience strange characters in the output, consider switching to a TrueType font such as Lucida Console! fatal: write error: Broken pipe " Is there a way to init a repository rather than push my first repo ? Where is the location of the repositories created by your app ?


  4. krazybug

    I tried again with a small repo and it's ok now.

    Thanks a lot !

    This program allows p2p workflows under windows without installing Cygwin or msysgit. I'll try it with hg now.

    Could you however answer to my previous questions (git init and repo location)

    Are there forums on bitbucket ?

  5. Sebastian Sdorra repo owner

    You can use the mailinglist ( or the bitbucket notification sytem instead of a forum. The repositories are located in .scm/repositories/git of the home directory from the user who owns the scm-manager process. What you mean with init? You could create a new repository and clone it.

    git clone http://localhost:8080/scm/git/yourrepositoryname

    I think this issue is resolved. When you have more questions please use mailinglist or the bitbucket notification system.

  6. Log in to comment