1. Sebastian Sebastian
  2. scm-manager
  3. Issues

Issues

Issue #284 resolved

Line ending conversion

Murat Ursavas
created an issue

Hi,

It's been some time since we've fixed the Turkish "i" character issue and started to use SCM Manager in our company. We are using it with joy and improved our productivity very well.

I'd like to use it a bit more productive and tried to use the web interface to view binary files. Sometimes to download the file without pulling all the repository.

I'm using source view to do that. Of course default view gives a soup of binary to ASCII characters but I'm able to download the file via clicking "RAW" button.

And the problem occures here. After downloading it to a remote machine we are not able to use it. I checked the underlying causes and saw that web interface pulls the file with converting "0x0A" bytes to "0x0D 0x0A".

Yes, can be easily seen, it tries to convert "\n" line endings to "\r\n". In other words LF -> CR LF. But this file is binary, it shouldn't do something like that.

So what can I do to fix that?

Thanks in advance.

P.S.: Version is 1.17 but it's a prerelease (SNAPSHOT) (sdorra sent me while working on the bug. Please look at the issue for details: https://bitbucket.org/sdorra/scm-manager/issue/195/authorization-failure-while-trying-to.)

Couldn't see any news in the release notes about this.

Comments (5)

  1. Sebastian Sebastian repo owner

    The problem with the turkish "i" was fixed in version 1.17. Here the line from the release notes:

    • fix basic authentication for systems with turkish locale, see #195

    Could you please upgrade to version 1.22, because the part of the repository access was completely rewritten in version 1.17 and 1.18.

  2. Murat Ursavas reporter

    Hi Sebastian,

    I haven't access to the server lately but I tried what you suggested this morning. And it worked. With version 1.22 viewing binary files is no problem. It does not manipulate the 0x0A byte.

    However, I've run into another issue with this version. I'm getting "Could not load items. Server returned error 500." error. And I'm getting this a lot. Should I open an another case for it or may we continue in here?

    P.S.: This error could have a similar source like the issue #195. Because the pattern shows that it regulary occures within the repositories with "i" character (or the folders in them).

  3. Log in to comment