HTTP authentication doesn't work for push with Egit

Issue #29 resolved
Thierry L.
created an issue

Hi, I got the following message when i tried to push a commit on repository hosted by scm-manager via Egit.

// An internal Exception occured during push: http://scmadmin@myhost:8080/scm/git/test: 401 Authorization Required//

My repository is configured with "write" access for the scmadmin user

When i tried again with msysgit it worked.

However the worakaround described in the following issues on Egit bugzilla didn't work

The url with password inside failed also http://scmadmin:scmadmin@myhost:8080/scm/git/test

The scm-manager consol diplays: //14:21:04.462 [qtp11108810-15] INFO sonia.scm.web.filter.PermissionFilter - write access to repostitory test for user anonymous denied //

scm-admin and Egit are running on Windows XP

Could you help me ?

Is it just a issue with Egit or with your software ?

Other question: does your software use dumb http protocol or smart ?

Best regards

Comments (25)

  1. Thierry L. reporter

    Could you provide some steps to produce this issue?

    1/ Get scm-manager and Eclipse+Egit installed on the same computer

    2/ Setup scm-manager with new hostname <myhost> (localhost) and a directory for git repos (d:\git)

    3/ Create a repo named "test" with "public" access

    4/ Set "write" permissions for the user "scmadmin" on this repo ("is group" unchecked)

    5/ Populate the empty repo with msysgit which creates the master branch (i will make a proposal on this topic later)

    cd D:\git\import
    git push http://scmadmin:scmadmin@<myhost>:8080/scm/git/test master

    The "import" repo contains just a simple file "test.txt"

    6/ Clone the "test" repo in Egit: Git repository perspective > button "Clone a Git reposi..." URI=http://scmadmin:scmadmin@<myhost>:8080/scm/git/test "Store in Secure Storage" checked or not doesn't change anything Location= "d:\Documents and Settings\<myuser>\test0.4 Then i get my new local repo "test0.4"

    7/ Right clic on the "Working directory" > "Import project" > "Import as a general project"

    8/ Switch to the Java perspective, edit the file "test.txt" and commit "Team" > "Commit"

    9/ Team "Push to upstream"

    10/ configure (a bug in Egit inserts "/r/p" in the push URI) select uri then "Change" and modify uri then "Save and push"


    An internal Exception occured during push: http://scmadmin@myhost:8080/scm/git/test: 401 Authorization Required

  2. Sebastian Sdorra repo owner

    Ok, i found a error in the git implementation of scm-manager, but this error only occurs if you have changed the location of the git repositories. Have you changed the location of the git repository (Repository Types->Git->Repository directory)?

  3. Log in to comment