Can not open repositories panel in scm manager

Issue #391 duplicate
Serge Kozlov created an issue

After creating and populating some git repositories I can not open repositories panel in scm manager to manage themes. Only this panel in not accessible, all other panels are opennable and functionable. This effect was observed after the first scm server "death". After 3 days of continous working the server ceased to respond to the requests. Push/pull requests hanged, there was no response from scm manager. I restarted windows service. The server recovered except for one function - accesibility to repositories panel. My environment – windows 2008 server web edition with all updates installed, scm server version 1.30 installed as windows service. I tried to renew this version by itself as discribed in instrution for updates, but none was changed. The repositories panel continues to be inaccessible.

Comments (20)

  1. Sebastian Sdorra repo owner
    • changed status to open

    Did you see any error in the "error console" of your browser? Or did you see an exception in the log of scm-manager?

  2. Serge Kozlov reporter

    I use firefox 20.0.1. Java version 1.6.0_45.

    You may find two scm-manager.log files and my screenshot in the first archive attached to this message.

    You may see on screenshot that all panels are opened. When I click on Repositories link occurs nothing.

    The error console writes “too much recursion” and points to the source “http://www.teleformis.ru:8480/scm/plugins/resources/js/f1deb9fd5d7eb087b18c69b64403e2ce0029b75a.js” where selects the string “Sonia.repository.openListeners.push(function(repository,panels){if(Sonia.repository.isOwner(repository))panels.push({xtype:"pathwpConfigPanel",item:repository})});if(Sonia.repository.Panel){Sonia.repository.Panel.prototype.initComponentExt=Sonia.repository.Panel.prototype.initComponent;Ext.override(Sonia.repository.Panel,{initComponent:function(){this.initComponentExt.apply(this,arguments);var viewStore=new Sonia.rest.JsonStore({proxy:new Ext.data.HttpProxy({url:restUrl+"views.json",disableCaching:false}),root:"views",fields:["label","restrictions"]});var tbar=this.getTopToolbar();tbar.add(" ",{xtype:"label",text:"View: "},{id:"viewFilter",xtype:"combo",hiddenName:"label",” . The text of the whole script attached. You may open it with firefox or other browser. Time stamp is “11.05.2013 12:09:07”. There are no errors in scm-manager.log at the same time.

    Thank you,

    Serge Kozlov

  3. Serge Kozlov reporter

    I changed from firefox to internet explorer 10 (32bit version) and retry.

    Here error console writes:

    SCRIPT28: There isn't enough place in a stack

    1662cb24ce7abfb2472e867c1c7e9635b4847cc0.js, line 73 character 63

    Line 73:

    Ext.override(Sonia.repository.Panel,{initComponent:function(){this.initComponentExt();if(!admin&&state.user.name!=="anonymous")this.checkPermissions()},checkPermissions:function(){Ext.Ajax.request({url:restUrl+"plugins/userrepo/ui.json",method:"GET",scope:this,disableCaching:true,success:function(response){var config=Ext.decode(response.responseText);if(this.isEmpty(config.groups)||this.isInGroups(config.groups))this.appendAddButton()},failure:function(){if(debug)console.debug("could not get userrepo config")}})},

    Error occurs after substring:

    Ext.override(Sonia.repository.Panel,{initComponent:function(){.

    Whole script attached.

    Microsoft internet explorer 10 (64bit version) produces the same result.

    Is it possible to increase stack size in firefox or MSIE ?

    Serge Kozlov

  4. Sebastian Sdorra repo owner

    You said i should look at the attached screenshot, but i could not see any attachment on this issue.

  5. Serge Kozlov reporter

    May be zipped script was filtered by firewall.

    I repeat with two passworded archives. Password – 111.

    Serge Kozlov

  6. Serge Kozlov reporter

    Here passworded script from firefox browser. Previous was from Microsoft IE.

    Password – 111.

    Serge Kozlov

  7. Sebastian Sdorra repo owner

    There are no attachment! How do you try to attach them? Please post the list of installed plugins as text.

  8. Serge Kozlov reporter

    I do not work with bitbucket and I use mail server teleformis.ru, which supports smtp and imap.

  9. Sebastian Sdorra repo owner

    Could you please use use the webinterface of bitbucket and post your installed plugins?

  10. Serge Kozlov reporter

    I unistalled some plugins. Currently installed are: activedirectory-auth, jira, mail, activity, branchwp, pathwp. Repository panel cannot be invoked.

  11. Serge Kozlov reporter

    I uninstalled scm-activity-plugin. Now installed only scm activedirectory-auth, jira, mail, branchwp and pathwp plugins. Repository panel became available. Thank you for ideas.

  12. Log in to comment