Issue #415 resolved

git push failed from remote client

created an issue

Hi, H'm a local lan with fixed ip (mine is using the scm manager 1.32 launched by the .bat in a Windows 7 Pro 64bit environment with JRE 7u21, the remote client is a virtual machine with Windows XP Pro sp3 32bit. In the real machine (Win7) I set the base url changing from localhost to my ip so it became: . From the virtual machine (I'll call it VM) I can clone, pull and obvously commit (I've installed on both machine Mysysgit for windows), the problem is when i try tu push to my "server", I execute:

git push origin master

and response was:

Password for 'http://lorex@':
Counting objects: 5, done.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 311 bytes, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Resolving deltas: 100% (1/1)
To http://lorex@
 ! [remote rejected] master -> master (unspecified reason)
error: failed to push some refs to 'http://lorex@

using the same url I can fetch, pulll ....

Comments (21)

  1. Sebastian Sdorra repo owner

    It looks like scm-manager can not find your repository during the prereceive hook. I can not reproduce the problem on my machine, so we have to find the problem on your installation. Could you please follow the steps below:

    • stop scm-manager
    • search the following line in your scm-server.bat
    set EXTRA_JVM_ARGUMENTS=-Djava.awt.headless=true -Dlogback.configurationFile=logging.xml
    • Replace the line with the following:
    set EXTRA_JVM_ARGUMENTS=-agentlib:jdwp=transport=dt_socket,server=y,address=5005 -Djava.awt.headless=true -Dlogback.configurationFile=logging.xml
    • Download youdebug from here
    • Download youdebug script here
    • start scm-manager with scm-server.bat
    • start youdebug:
    java -jar youdebug-1.5-jar-with-dependencies.jar -socket 5005 GitRepositoryNotFoundOnPush.ydb
    • reproduce the issue
    • post the output from youdebug

    I know it is terrible, but i do not know a better way to debug this issue.

  2. redips reporter

    Hi, I followed your instructions (and copied the .jar and the .ydb in the bin dir) but running the modified scm-server.bat it outputs (is it correct?):

    Listening for transport dt_socket at address: 5005

    and I think I'm missing some files launching youdebug.bat (a bat with the command line you suggested:

    E:\download\GIT\git_web_server\scm-server-1.32\bin>java -jar youdebug-1.5-jar-wi
    th-dependencies.jar -socket 5005 GitRepositoryNotFoundOnPush.ydb

    I get:

    Specify the location of tools.jar via -toolsJar, or run this tool with JDK (your
     java home is at C:\Program Files\Java\jre7)
    Usage: java -jar youdebug.jar [options...] [script file]
     -debug              : Increase the debug output level. Specify multiple times
                           to get more detailed logging
     -pid N              : Attaches to the local process of the given PID
     -socket [HOST:]PORT : Attaches to the target process by a socket
     -toolsJar JAR       : Specify the location of the tools.jar, if it's in a
                           non-standard location

    In this way the log file under my home dir / .scm contains only the old attempts of this morning, but nothing of this new execution with debugging tools you gave to me. I hope my english is understandable

  3. redips reporter

    Hi, I've installed the JDK instead of JRE, no problem! Again thanks for the support! If I wasn't not clear actually the VM is running on my Win 7 where scm-manager is running but should be enough to be considered "remote" :-) I've executed with the debugging tools, tried the remote push from the virtual machine and here you'll find the attached log file.

  4. redips reporter

    Uh, ops sorry! :) so the output is:

    RepositoryUtil:244: baseDirectory=E:\git:6,directory=E:\git\prova_bitbucket\.git
    RepositoryUtil:249: name with trimSeperatorChars = prova_bitbucket\.git
    GitReceiveHook:133: fire hook event for git repository prova_bitbucket/.git
    GitReceiveHook:133: the repository is located at E:\git\prova_bitbucket\.git
  5. Sebastian Sdorra repo owner

    Thanks. The output shows a repository name "prova_bitbucket.git" but your repository is called "prova_bitbucket" is that correct? Which client do you use for the push?

  6. redips reporter

    Uh ok, how are you fast? :) Anyway I'v set the pat to the git repositories (in my case in the E: partition E:\git) and after I used "Import Repositories" checking just the git option.

  7. redips reporter

    Hi, wow thank you! But... same error:

    To http://lorex@
     ! [remote rejected] master -> master (unspecified reason)
    error: failed to push some refs to 'http://lorex@


    Do I have to prepare the same debug options you suggested bedore and post the youdebug log as before?

  8. redips reporter

    I was wrong, now with that versione you passed me is WORKING!!!! Please commit and push to your project! ;) Thank you so much!!!

  9. Log in to comment