Issue #57 resolved

Login not working?

Anonymous created an issue

I've tried this on the released version of scm-manager 1.6 and 1.7, but the activedirectory-plugin doesn't seem to allow a login. If i install the plugin, restart the server, and login as admin I get all the web-based active directory items (add permissions to repos, etc). However, if i log out and try to log in as my active directory account it says failed login.

I pulled a copy of the source and ran scm-webapp using mvn jetty:run I've been able to get the activedirectory-plugin to work that way, and allow a login of my active directory account. Is there something i'm doing wrong/missing between the released version, and the source code version? (For clarification i did the hg clone for the source about 4 days ago).

Comments (12)

  1. Chuck Rolek

    haster == OP

    And yes I did follow the steps on your link above.

    I watch the command console when I'm running the .bat file and then when I'm running it with the jetty:run style. When i run the bat file, do the install process, restart the server, and come back i see the plug-in as actively there. However, when i try to logout and login as my AD the login fails and the console reports nothing. Its almost as if the plugin isn't getting hit on login. However, if i do it with the jetty:run style my console will relay messages along the lines of its attempting the login, login AD groups found, login successful. Any thoughts?


  2. Chuck Rolek

    Unfortunately I can't, because it literally won't display anything. I just had to restart my computer, but i'll see if i can get you a console to console comparison.

  3. Chuck Rolek
    • edit* see attached .png file

    The top console is from your .bat file. The last line that is in the console is the start server. This is AFTER i tried to login as my AD user. As you can see nothing happened on the console end and the login failed.

    The second console is me doing the jetty:run. As you can see it attempts the login, eventually returns successful, adds me to the users.xml, and then displays my AD groups. The login on this one is successful.

    Hopefully this helps.

  4. Sebastian Sdorra repo owner

    Could you please enable trace logging, try it again and post the output.

    Enable debug logging:

    • Edit scm-server/conf/logging.xml
    • Change the line from: <logger name="sonia.scm" level="INFO" />
    • to: <logger name="sonia.scm" level="TRACE" />
  5. Chuck Rolek

    below is a console log of what it looks like when i login as scmadmin and then as myself after I made your change above.


    2011-09-13 08:06:58.258:INFO::started o.e.j.w.WebAppContext{/,[file:/C:/..._/scm-server/1.7/var/webapp/docroot/]}

    2011-09-13 08:06:58.290:INFO::Started SelectChannelConnector@ STARTING

    08:07:42.773 [qtp930501550-22] DEBUG

    dler - user scmadmin logged in successfully

    08:07:42.776 [qtp930501550-22] DEBUG

    nager - authenticator ends with

    result, user: scmadmin, state: SUCCESS

    08:07:42.781 [qtp930501550-22] DEBUG

    - user scmadmin is not a member of a group

    08:07:43.175 [qtp930501550-17] DEBUG sonia.scm.repository.AbstractRepositoryMana

    ger - register POST_RECEIVE hook class sonia.scm.repository.ChangesetViewerUtil

    08:07:43.176 [qtp930501550-17] DEBUG sonia.scm.repository.AbstractRepositoryMana

    ger - register POST_RECEIVE hook class sonia.scm.repository.RepositoryBrowserUti

    l 08:07:54.456 [qtp930501550-22] DEBUG

    dler - <myusername> is not an xml user

    08:07:54.456 [qtp930501550-22] DEBUG

    nager - authenticator ends with

    result, user: null, state: NOT_FOUND

    08:07:54.457 [qtp930501550-22] DEBUG

    nager - authenticator sonia.scm.activedirectory.auth.ActiveDirectoryAuthenticati

    onHandler ends with result, null

  6. Chuck Rolek

    Yes, I am technically on a Windows 7 64 bit system. When i run the source code with the mvn jetty:run does that mean that the command prompt is running things as 32 bit?

    And thank you for helping me determine that that was the problem. I'll see if i can get my hands on a 32 bit system to confirm that solution.


    Does that mean that if i put this on a 32 bit server, and have 64 bit users trying to connect to it with their AD account that they will be unable to do it with the current state of this plugin?

    Double edit

    upon opening a 32bit command prompt, navigating to your /bin/ and doing scm-server i was able to successfully start my server in 32bit mode. However my question from the original edit is still active.

    Thank you again for helping me with this.

  7. Log in to comment