ERROR sonia.scm.web.HgCGIExceptionHandler - not able to handle mercurial reques

Issue #614 closed
Enrico Suarez
created an issue

Whenever I try pushing to scm-manager using Mercurial, I always get abort: authorization failed

Using: Mercurial 3.0.1 SCM Manager 1.40

Comments (16)

  1. Sebastian Sdorra repo owner

    The exceptions are look like a client abort. Could you try to do the push directly on the server which runs scm-manager, just to be sure it is not a problem of a network component. Do you use a reverse proxy?

  2. Enrico Suarez reporter

    I do use Nginx as a reverse proxy, but I've also tried without, with the same result. I don't get issues with SVN though.

    I'll try running a push directly on the server to test.

  3. Enrico Suarez reporter

    Pushing from the same server as scm-manager (straight to the jetty port) got me "abort: HTTP Error 403: Forbidden". I'm sure I have the correct credentials though, since I've just used it to clone the repo.

    I've also confirmed the group my user is in has write permissions to said repo.

  4. Enrico Suarez reporter

    Hi, the user has permissions--the setup is that the user is part of a Dev group. But I also tried adding the user to the permissions list directly, with the same result.

    And, no I did not install the pathwp plugin.

  5. alexey_kuptsov

    Had a very similar issue after converting Mercurial repos to support largefiles. Just as mentioned above, push to imported repositories failed with 403 forbidden and 'unable to handle Mercurial request' in logs. However, a newly created repository worked alright.

    After reading this thread I checked hgrc files in repos and they were actually missing in converted repositories! Not sure if it's an lfconvert issue or caused by some import error.

    Anyway, copying hgrc from newly created (via SCM Manager webface) repo to imported ones fixed the problem - it actually contains push permissions.

  6. Log in to comment