Error - Bad Response

Create issue
Issue #47 new
Dezipter created an issue

Hello Shana Project, For some reason, after I reinstalled my mac os x and Vuze which resets my RSS Feed. I've been having trouble with the RSS Feed Scanner on Vuze Aezarus for mac.

I'm constantly getting an Error -Bad Response.

I've attached a picture of the RSS Feed Scanner (with UID Removed).

Thanks for the Website, and I'd appreciate the help.

Comments (13)

  1. Shana Project repo owner

    The links in your feed should be fine. They redirect and download fine in a web browser; so there is no reason they shouldn't in a bittorrent client. I have noticed the web server seems to take a while to serve the .torrent file (after we do an internal redirect), so we'll look into seeing if this could be causing potential problems.

    Have you tried a different torrent client? Might be worth it simply to make sure there are no other network oddities getting in the way.

  2. Stephen

    I've also been getting this error, it reports as a 302 error. I'm using the same plugin on Vuze though I'm on a windows machine. I can download the link it provides just fine if I pull out the URL and do it manually.

    I would say this is an RSSFeed issue except it was working fine yesterday and without any patching to the plugin, it broke, Which normally is unusual.

    I've also just attempted to grab the same torrent using Utorrent. On the first attempt the down-loader seemed to simply throw the torrent away. This behavior has happened every so often in the past, it's the reason I moved back to Vuze, but it was simple enough to grab the torrent manually from the same source when I noticed it.

    With this example however I get an "Unable to load" error reporting the URL as well as "Could not obtain SSL chunk size".

    Hope this helps.

  3. Stephen

    I did some looking around and found out that this might be an issue with using a proxy.

    I attempted the same tests as before without the proxy and the issue persists.

  4. Shana Project repo owner

    We did make a change last night to force downloads to go via https links. This means that the http download link will redirect to the https file. There shouldn't be any problem with this though (and it certainly works as far as I can tell). The error message you're getting doesn't lead anywhere helpful so I'm a bit stumped for what to do (I could simply turn https back off... but that is sub-optimal).

  5. Shana Project repo owner

    A quick test on my end indicates uTorrent (3.3) and Deluge (Windows) both handle this fine.

    Are you able to send some individual files (one at a time), then refresh Vuze and see what logging comes out (turn up any logging if possible...?) Also, if you can catch me on IRC we might be able to nut through the issue a bit better.

  6. Stephen

    It seems to have solved itself. I'm pulling torrents from the RSS feed and running them without incident

    If it happens again I'll look for any logging features I can and see if I can't also filter some relevant networking logs from my router.

  7. Shana Project repo owner

    I rolled back the https change, so it proves that that was the problem (if we didn't already know that)... but doesn't actually solve anything =\

  8. Stephen

    I'll send an email to the developer of RSSFeed Scanner. If they need to add support for https for some reason then it just needs to be done. This plugin is the most capable for RSS feed integration on the VUZE client that I know of. I've tried one of the other one's and it simply doesn't support proper automation.

    I'll get this done tomorrow however as it's getting to the end of my day. I'll also see if there aren't any other plugin's that can do this job just as well.

  9. Shana Project repo owner

    I'm not 100% sure if its the plugin, since you said it happened with uTorrent too didn't you? (Where-as mine works fine); and I think I heard someone say they had the issue with what I'm guessing was Deluge?

    My first thought is that the 302 redirect is causing problems because it switches from http to https (after the redirect). But I don't understand why it would work fine for some people but not others.

  10. Stephen

    I was just thinking that as I was going to sleep last night. I have switched my feed url from an http protocol to the https. I'm thinking that might have been causing the issue. That would fit normal troubleshooting procedure, bend over backwards to solve a problem and then realize that the solution is to add one letter somewhere.

    If you re-implement the https on your end I'll test it again.

  11. Shana Project repo owner

    Ok. So we've fixed this issue as related to https. I don't think the issue was actually related to the initial issue from Dezipter though...

  12. Dezipter reporter

    @Shana Project & @Stephen Inwood

    Eh, My Barracuda HDD bit the dust a long while ago.

    I did enjoy watching you guys fix this issue :D

    Maybe when I get my bonus, I'll get the setup running again.

    p.s. I'm also considering switching to an older lightweight version of UTorrent. See if it'll help reduce power consumption. Been running it off a 2007 mac mini, but hell less power = more money for me.

    Or any setup you guys would like to recommend?


  13. Shana Project repo owner

    My recommendation is now Deluge. It's a daemon, so fairly light weight. You then use a client (or web interface) to interact with it. It also supports the new SP feature of downloading direct to folders.

  14. Log in to comment