1. Danno Ferrin
  2. javafx-gradle
  3. Issues
Issue #16 resolved

just trying to get going

Tom Eugelink
created an issue

We're in the process of creating a new JFXtras samples project (in conjuction with ControlsFX), and I'm trying to create a webstart for this project. I figured the javaFX plugin for Gradle is a good start. Being a noob at Gradle, I googled the interwebz and found a few examples and tutorials, but I'm still getting stuck.

The project has the maven directory structure, it has the following in the build.gradle: javafx { appID 'JFXtrasSamples' appName 'JFXtras samples' mainClass 'fxsampler.FXSampler' }

And I run 'gradlew assemble'. The error that I'm getting is:

:compileJava UP-TO-DATE :processResources UP-TO-DATE :cssToBin UP-TO-DATE :classes UP-TO-DATE :javadoc UP-TO-DATE :docJar UP-TO-DATE :jar :jfxJar :jfxSignJar SKIPPED :jfxCopyLibs FAILED

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':jfxCopyLibs'.

    Warning: Could not find file C:\Users\user\Documents\jfxtras-labs-samples\buil d\libs\jfxtras-labs-samples-8.0-r1-SNAPSHOT-sources.jar to copy.

Comments (7)

  1. Danno Ferrin repo owner

    The plugin also interacts with the other registered libraries and dependencies, which I presume includes the sources jar at some point. Any chance I could see the whole build.gradle?

  2. Danno Ferrin repo owner

    This is broken in 0.3.0, and fixed in the 0.4.0-snapshot builds. not sure specifically what I did to fix it, but I've reproduced your break and changing it to 0.4.0-SNAPSHOT worked.

    Don't get too excited, the fxsampler codebase needs some work however.

  3. Tom Eugelink reporter

    Can you be a tad more specific? fxsampler is not my project, but is supposed to become a generic run-the-javafx-samples application, currently developed by Jonathan Giles.

    Tom

  4. Log in to comment