Commits

Shlomi Fish  committed 76283b7

Minimal version of perl

  • Participants
  • Parent commits 26b25de

Comments (0)

Files changed (5)

File modules/Mail-LMLM/Build.PL

 
 my $build = Test::Run::Builder->new(
     'module_name' => "Mail::LMLM",
-    'build_requires' => 
+    'build_requires' =>
     {
         'Test::More' => 0,
     },
     'requires' =>
     {
+        'perl' => '5.008',
         'strict' => 0,
         'vars' => 0,
         'warnings' => 0,

File modules/Mail-LMLM/Changes

         - it previously used Test.pm and plain ok()s after use statements.
         - Test.pm is no longer recommended.
     - Enhance the Build.PL with keywords, resources, requires and build_requires.
+    - Minimal version of perl is 5.008.
 
 0.6801    ( Fri Feb 26 13:20:42 IST 2010 )
     - Correct the Google groups' mailing list homepage.

File modules/Mail-LMLM/META.yml

 build_requires:
   Test::More: 0
 configure_requires:
-  Module::Build: 0.38
+  Module::Build: 0.40
 dynamic_config: 1
-generated_by: 'Module::Build version 0.38, CPAN::Meta::Converter version 2.120630'
+generated_by: 'Module::Build version 0.4007, CPAN::Meta::Converter version 2.132830'
 keywords:
   - E-mail
   - 'mailing lists'
     version: 0.6802
   Mail::LMLM::Object:
     file: lib/Mail/LMLM/Object.pm
-    version: 0
   Mail::LMLM::Render:
     file: lib/Mail/LMLM/Render.pm
-    version: 0
   Mail::LMLM::Render::HTML:
     file: lib/Mail/LMLM/Render/HTML.pm
-    version: 0
   Mail::LMLM::Types::Base:
     file: lib/Mail/LMLM/Types/Base.pm
-    version: 0
   Mail::LMLM::Types::Egroups:
     file: lib/Mail/LMLM/Types/Egroups.pm
-    version: 0
   Mail::LMLM::Types::Ezmlm:
     file: lib/Mail/LMLM/Types/Ezmlm.pm
-    version: 0
   Mail::LMLM::Types::GoogleGroups:
     file: lib/Mail/LMLM/Types/GoogleGroups.pm
-    version: 0
   Mail::LMLM::Types::Listar:
     file: lib/Mail/LMLM/Types/Listar.pm
-    version: 0
   Mail::LMLM::Types::Listserv:
     file: lib/Mail/LMLM/Types/Listserv.pm
-    version: 0
   Mail::LMLM::Types::Mailman:
     file: lib/Mail/LMLM/Types/Mailman.pm
-    version: 0
   Mail::LMLM::Types::Majordomo:
     file: lib/Mail/LMLM/Types/Majordomo.pm
-    version: 0
 requires:
+  perl: 5.008
   strict: 0
   vars: 0
   warnings: 0

File modules/Mail-LMLM/Makefile.PL

-# Note: this file was auto-generated by Module::Build::Compat version 0.3800
+# Note: this file was auto-generated by Module::Build::Compat version 0.4007
+require 5.008;
 use ExtUtils::MakeMaker;
 WriteMakefile
 (
-  'PL_FILES' => {},
-  'INSTALLDIRS' => 'site',
   'NAME' => 'Mail::LMLM',
-  'EXE_FILES' => [],
   'VERSION_FROM' => 'lib/Mail/LMLM.pm',
   'PREREQ_PM' => {
-                   'warnings' => 0,
+                   'Test::More' => 0,
                    'strict' => 0,
-                   'Test::More' => 0,
-                   'vars' => 0
-                 }
+                   'vars' => 0,
+                   'warnings' => 0
+                 },
+  'INSTALLDIRS' => 'site',
+  'EXE_FILES' => [],
+  'PL_FILES' => {}
 )
 ;

File modules/Mail-LMLM/lib/Mail/LMLM.pm

 
 use strict;
 
+use 5.008;
+
 use Mail::LMLM::Object;
 
 use vars qw($VERSION);