Commits

Anonymous committed 425d796

Modified Files:
README Changes
version notes

Makefile.PL
(required by iterator classes)
added XML::NodeFilter as a required modules

Comments (0)

Files changed (3)

 versions of the package. 
 
 1.54
+   - XML::NodeFilter support for iterator classes
+   - bad tag and attribute names cannot be created anymore
    - Catalog interface is aware about libxml2 configuration
-   - XML::LibXML should work now on system without having zlib installed (?)
+   - XML::LibXML should work now on systems without having zlib installed
    - cleaned the error handling code, which 
      - fixes bad reporting of the validating parser
      - fixes bad reporting in xpath functions
      (that fixes a lot strange things)
    - fixed default iterator of XML::LibXML::Iterator
    - interface for raw libxml2 DOM building functions 
-     (currently just addChild(), others will follow)
+     (currently just addChild() and addNewChild(), others will follow)
    - fixed memory leak in push parser code
    - fixed namespace handling if nodes are imported to a new DOM.
    - fixed segmentation fault during validation under libxml2 2.4.25
    - fixed memory leak       in XML::LibXML::Document
    - fixed segfault while appending entity ref nodes to documents
    - fixed some backward compatibility issues
+   - fixed cloning with namespaces misbehaviour
    - improved parser testsuite
    - more documentation 
 
     'PREREQ_PM' => { 'XML::SAX' => '0.11',
                      'XML::NamespaceSupport' => '1.07',
                      'XML::LibXML::Common' => 0,
+                     'XML::NodeFilter' => 0,
                    },
     'OBJECT'    => '$(O_FILES)', # add the DOM extensions to libxml2
     'dist'      => { PREOP => "$^X -Iblib/arch -Iblib/lib example/xml2pod.pl" },
 programs written for XML::LibXML 1.40 or less should run with 
 version 1.50 again.
 
-Installation
+Dependencies
 ============
 
 Prior to installation you MUST have installed the libxml2
 
       http://xmlsoft.org
 
-Since there are some versions around that can be used with XML::LibXML,
-there are some things to mention here:
+Also XML::LibXML requires the following packages:
+
+XML::LibXML::Common   - node type symbols and encoding functions
+XML::SAX              - DOM building support from SAX
+XML::NamespaceSupport - DOM building support from SAX
+XML::NodeFilter       - Filter Class for XML::LibXML::Iterator
+                        and XML::LibXML::NodeList::Iterator
+
+These packages are required. If one is missing some tests most likely
+will fail.
+
+Installation
+============
 
 Then run:
 
 > 
 > perl Makefile.PL LIBS='-L/path/to/lib' INC='-I/path/to/include'
 
+NOTES FOR Mac OS X
+==================
+
+XML::LibXML 1.54 is known not to work with Max OS X because of the known
+'flat namespace' linking problem. This leads to conflicts with 
+XML::LibXML::Common. I am aware that there are sollutions to this 
+problem, but because of a lack of hardware I was not able to solve this
+problem for this release. 
+
 NOTES FOR M$ Windows
 ====================
 
 Package History
 ===============
 
-Version < 0.98 were implemented by Matt Sergeant 
+Version < 0.98 were maintained by Matt Sergeant 
 0.98 > Version > 1.49 were maintained by Matt Sergeant and Christian Glahn
 Version >= 1.49 are maintained by Christian Glahn
  
 
 Copyright 2001-2002 AxKit.com Ltd, All rights reserved.
 
-
 DISCLAIMER
 ==========