Commits

Anonymous committed e156043

Modified Files:
README
installation hints

Changes
more verbose versionlog

Makefile.PL
minor fix (made XMLPREFIX work correct)

  • Participants
  • Parent commits 5cd76df

Comments (0)

Files changed (3)

 manpage!
 
 1.50
+   - fixed major problems with the validating parser
+   - fixed default behaviour of the generic parser
+   - fixed attribute setting of the string parser
+   - fixed external entity loading for entity expansion
+   - fixed nodeValue() to handle entities and entity refs correctly
+   - compatibility fixes
+   - importNode() bug fix 
+   - fixed library tests and output in Makefile.PL
+   - added setOwnerDocument() again
+   - XML::LibXML::Document::process_xincludes reintroduced
+   - global callbacks reintroduced
+     NOTE: the Interface changed here, read XML::LibXML manpage!
+   - code cleanings
    - push parser interface
-   - fixed major problems with the validating parser
-   - XML::LibXML::Document::process_xincludes reintroduced
-   - Class wide callbacks added 
-   - code cleanings
-   - fixed library tests and output in Makefile.PL
-   - more documentation
-   - importNode() bug fix 
-   - fixed external entity loading for entity expansion
-   - compatibility fixes
    - basic native libxml2 SAX interface
      THIS INTERFACE IS STILL EXPERIMENTAL
    - cloneNode clones now within documents
+   - more documentation
 
 1.49
    - memory management has been completely rewritten.
 # get libs and inc from gnome-config
 eval {
     my $xml2cfg = "xml2-config";
-    if ( defined $config{XMLPREFIX} ) {
-        $xml2cfg = $config{XMLPREFIX} . '/' . $xml2cfg;
+    if ( defined $ENV{XMLPREFIX} ) {
+        $xml2cfg = $ENV{XMLPREFIX} . '/bin/' . $xml2cfg;
     }
     print "running xml2-config... ";
     my $ver = backtick("$xml2cfg --version");
 ============
 
 Prior to installation you MUST have installed the libxml2
-library.
+library. You can get the latest libxml2 version from 
+
+      http://xmlsoft.org
 
 Then run:
 
 starts in perldoc XML::LibXML::Document and perldoc
 XML::LibXML::Node.
 
+If your libxml2 installation is not within your $PATH. you can set 
+the environment variable XMLPREFIX=$YOURLIBXMLPREFIX to make 
+XML::LibXML recognize the correct libxml2 version in use.
+
+e.g.
+
+$ XMLPREFIX=/usr/brand-new perl Makefile.PL
+
+will ask '/usr/brand-new/bin/xml2-config' about your real libxml2 configuration.
+
 This is free software, you may use it and distribute it under the same
-terms as Perl itself. Copyright 2001 AxKit.com Ltd, All rights reserved.
+terms as Perl itself. 
 
+Copyright 2001-2002 AxKit.com Ltd, All rights reserved.
+