Commits

Anonymous committed e983af5

Modified Files:
19encoding.t
+ skips with perl 5.7+
this is required, since more recent versions than perl 5.6x
require the code in UTF8. therefore magic encoding is only available
for data that is not already converted to UTF8 (which we can't test
from the code anymore)

Comments (0)

Files changed (1)

         
     }
 
-    $tests = 1 if $] > 5.007;
-
+    if ( $] > 5.007 ) {
+	    print "1..0 # Skipping tests on this platform\n";
+        exit(0)
+    }
     plan tests => $tests;
 }
 
-END { ok(0) unless $loaded }
+END { ok(0) unless $loaded and $] < 5.007 }
+
 use XML::LibXML;
 $loaded = 1;
 ok(1);
 
-warn "skip tests on this platform\n" if $] > 5.007;
 
 my $p = XML::LibXML->new();