Commits

Shlomi Fish  committed 9ee55d5 Merge

Committed

  • Participants
  • Parent commits 8b83daa, dab518b

Comments (0)

Files changed (8)

+Dist-Man/Dist-Man/blib
+Dist-Man/Dist-Man/_build
 Dist-Man/Dist-Man/Build
+Dist-Man/Dist-Man/Makefile.PL
 Dist-Man/Dist-Man/META.yml
 Dist-Man/Dist-Man/MYMETA.yml
-Dist-Man/Dist-Man/Makefile.PL
-Dist-Man/Dist-Man/_build
-Dist-Man/Dist-Man/blib
+Module-Format/Module-Format/blib
+Module-Format/Module-Format/_build
 Module-Format/Module-Format/Build
+Module-Format/Module-Format/Makefile.PL
 Module-Format/Module-Format/META.yml
 Module-Format/Module-Format/MYMETA.yml
-Module-Format/Module-Format/Makefile.PL
-Module-Format/Module-Format/_build
-Module-Format/Module-Format/blib
+Text-Format/Text-Format/blib
+Text-Format/Text-Format/_build
 Text-Format/Text-Format/Build
+Text-Format/Text-Format/Makefile.PL
+Text-Format/Text-Format/META.json
 Text-Format/Text-Format/META.yml
+Text-Format/Text-Format/MYMETA.json
 Text-Format/Text-Format/MYMETA.yml
-Text-Format/Text-Format/_build
-Text-Format/Text-Format/blib
 3dc7909c6514e6f70253f5243b84493dc269b853 Text-Format-0.52
 8d8aee731ea8626ab253d4dab21eaaddf6d568d7 Text-Format-0.53
 21b6e0864700050e44ef823637a8c1cae261b2cf Module-Format-v0.0.4
+7d7dd4cf7b12260731db763c7d01200f597e610d Text-Format-0.54
+7d7dd4cf7b12260731db763c7d01200f597e610d Text-Format-0.54
+c53883b40de6df13b29bfc40094c826e00ab4453 Text-Format-0.54
+52ec9328d23a7654b064e87bdd29d0c6a9c12e27 Text-Format-0.55
+8be1759c2d87ba7111445ac98c7cd536c74a8325 Text-Format-0.56
+8be1759c2d87ba7111445ac98c7cd536c74a8325 Text-Format-0.56
+4d86a7aed25fe51097e507de640042d3ab54f506 Text-Format-0.56

File Text-Format/Text-Format/Changes

 Revision history for Perl extension Text::Format.
 
-0.54 Tue  4 Sep 14:01:10 IDT 2012
+0.57 Tue  4 Sep 14:01:10 IDT 2012
     - Clarified the documentation regarding noBreak and noBreakRegex.
         - Thanks to Anne Wainwright.
 
+0.56 Thu May 31 09:23:26 IDT 2012
+    - Add "use warnings;" to lib/Text/Format.pm .
+    - Add t/pod.t .
+    - Add t/pod-coverage.t .
+
+0.55 Thu May 31 09:17:32 IDT 2012
+    - Fix small spelling error in the POD:
+        - closing https://rt.cpan.org/Ticket/Display.html?id=77481
+        - Thanks to Salvatore Bonaccorso and the Debian people
+        for the report and the patch.
+        - ( There were also some duplicate bug report in the rt.cpan.org queue 
+        by accident. )
+
+0.54 Fri May 25 02:33:47 IDT 2012
+    - Convert t/justify.t and t/format.t to Test::More, "use strict;"
+    and "use warnings;" and cleaned them up.
+        - fix a warning generated by a call to defined(@array)
+            - https://rt.cpan.org/Ticket/Display.html?id=77413
+            - thanks to H. Merijn Brand for the report.
 0.53 Fri Jan 28 13:02:01 IST 2011
     - Adopted by Shlomi Fish (while disclaiming all rights).
     - Convert the build system to Module-Build, while adding keywords

File Text-Format/Text-Format/MANIFEST

 lib/Text/Format.pm
 t/format.t
 t/justify.t
+t/pod.t
+t/pod-coverage.t
 MANIFEST
 Makefile.PL
 META.yml

File Text-Format/Text-Format/Makefile.PL

-# Note: this file was auto-generated by Module::Build::Compat version 0.39_01
-use ExtUtils::MakeMaker;
-WriteMakefile
-(
-  'NAME' => 'Text::Format',
-  'VERSION_FROM' => 'lib/Text/Format.pm',
-  'PREREQ_PM' => {
-                   'Carp' => 0,
-                   'Test::More' => 0,
-                   'strict' => 0,
-                   'vars' => 0,
-                   'warnings' => 0
-                 },
-  'INSTALLDIRS' => 'site',
-  'EXE_FILES' => [],
-  'PL_FILES' => {}
-)
-;

File Text-Format/Text-Format/lib/Text/Format.pm

 use strict;
 use vars qw($VERSION);
 
-$VERSION = '0.54';
+$VERSION = '0.56';
 
 # local abbreviations, you can add your own with abbrevs()
 my %abbrev = (

File Text-Format/Text-Format/t/pod-coverage.t

+use strict;
+use warnings;
+use Test::More;
+
+# Ensure a recent version of Test::Pod::Coverage
+my $min_tpc = 1.08;
+eval "use Test::Pod::Coverage $min_tpc";
+plan skip_all => "Test::Pod::Coverage $min_tpc required for testing POD coverage"
+    if $@;
+
+# Test::Pod::Coverage doesn't require a minimum Pod::Coverage version,
+# but older versions don't recognize some common documentation styles
+my $min_pc = 0.18;
+eval "use Pod::Coverage $min_pc";
+plan skip_all => "Pod::Coverage $min_pc required for testing POD coverage"
+    if $@;
+
+all_pod_coverage_ok();

File Text-Format/Text-Format/t/pod.t

+#!perl -T
+
+use strict;
+use warnings;
+use Test::More;
+
+# Ensure a recent version of Test::Pod
+my $min_tp = 1.22;
+eval "use Test::Pod $min_tp";
+plan skip_all => "Test::Pod $min_tp required for testing POD" if $@;
+
+all_pod_files_ok();