Issue #5 resolved

CMake Error at CMakeLists.txt:10 (STRING)

Mark Gardner
created an issue

After installing the necessary Perl modules I still get the attached error on CentOS Linux 6.2 on x86_64.

Comments (8)

  1. Shlomi Fish repo owner

    Hi Mark,

    yes, currently one needs to explicitly specify CMAKE_INSTALL_PREFIX and LIB_INSTALL_DIR as arguments to CMake. I'm using the following script to build CMake:

      cmake -DCMAKE_BUILD_TYPE=release \
        -DCMAKE_INSTALL_PREFIX="$HOME/apps/test/wml" \
        -DLIB_INSTALL_DIR="$HOME/apps/test/wml/lib" \
        ..
    

    I guess I need to gracefully handle this edge case as well, because I've also ran into it.

    Regards,

    -- Shlomi Fish

  2. Mark Gardner reporter

    Using that script I still get an error, although the numbers have changed. I think you're relying on a feature introduced in CMake 2.8; I'm using CMake 2.6.4.

    gardnerm@gsi-14372-centos6 ~/src/wml-2.2.0/build
    $ ../build.bash 
    -- The C compiler identification is GNU
    -- The CXX compiler identification is GNU
    -- Check for working C compiler: /usr/lib64/ccache/gcc
    -- Check for working C compiler: /usr/lib64/ccache/gcc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Check for working CXX compiler: /usr/lib64/ccache/c++
    -- Check for working CXX compiler: /usr/lib64/ccache/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    CMake Error at CMakeLists.txt:14 (STRING):
      string end index: -1 is out of range 0 - 3
    
  3. Shlomi Fish repo owner

    Myunghoon Kim: first of all I should note that you should be able to find a binary .rpm of wml for CentOS - at least there is one for Mandriva Linux/Mageia Linux. wml-2.0.x should work fine as well (the only major change from wml-2.0.x was the conversion to CMake).

    Otherwise, it is highly possible that the error you are getting with pod2man is due to the perl shipped with CentOS 6.2 which is only perl-5.10.1-119.el6_1.1.x86_64.rpm whereas the currently supported perls are 5.14.2 and 5.16.0 . That or it is caused by a downstream patch of the perl package in RHEL/CentOS, which is notorious for that. Nevertheless, I will try to investigate all that.

    Regards,

    — Shlomi Fish

  4. Shlomi Fish repo owner

    @mjgardener : I was now able to successfully build wml's hg trunk using cmake-2.8.7 on CentOS 6.3 using its /usr/bin/perl after installing some dependencies. So it seems to be OK.

    I'm closing this bug - please comment or open a new one if you're still running into problems.

  5. Log in to comment