Clone wiki

gengine / Prerequisites

Prerequisites to build the engine


Engine and some of the demo code builds cleanly under modern compilers. VS 2008 - 2010 should be just right.

Direct X

Latest directs SDK should be just fine. Make sure its registered with Visual Studio, e.g. header and lib search path points at the right directory. Move them to the top of the list (higher priority) if you have Platform SDK installed (which may include an outdated DX version).


This steps are not necessary right at the moment, however its just for now.


Download, build and install boost library. Boost home directory should be located at the same parent directory as the project source code. Ensure VS has a include and lib path pointing to the right places.


Download and install from CMake home page