EditorSerialization Format EnumSelector Not working on Any Of Them

Issue #317 resolved
Former user created an issue

1).

Could not get serialized property for type EnumSelector<DataFormat>; this type will not be shown in the inspector.
UnityEngine.Debug:LogWarning(Object)
Sirenix.OdinInspector.Editor.InspectorPropertyInfo:PopulateUnityProperties(Type, List`1) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/Infos/InspectorPropertyInfo.cs:1123)
Sirenix.OdinInspector.Editor.InspectorPropertyInfo:CreateInspectorProperties(Type, Boolean) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/Infos/InspectorPropertyInfo.cs:545)
Sirenix.OdinInspector.Editor.InspectorPropertyInfo:Get(Type, Boolean) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/Infos/InspectorPropertyInfo.cs:511)
Sirenix.OdinInspector.Editor.PropertyTree`1:.ctor(EnumSelector`1[], SerializedObject) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/PropertyTree.cs:732)
System.Activator:CreateInstance(Type, Object[])
Sirenix.OdinInspector.Editor.PropertyTree:Create(IList, SerializedObject) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/PropertyTree.cs:539)
Sirenix.OdinInspector.Editor.PropertyTree:Create(IList) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/PropertyTree.cs:438)
Sirenix.OdinInspector.Editor.PropertyTree:Create(Object) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Core/PropertyTree.cs:397)
Sirenix.OdinInspector.Editor.OdinEditorWindow:UpdateEditors() (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/OdinEditorWindow/OdinEditorWindow.cs:642)
Sirenix.OdinInspector.Editor.OdinEditorWindow:OnGUI() (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/OdinEditorWindow/OdinEditorWindow.cs:487)
UnityEditor.HostView:OnGUI()

2). Try to click on Tools > Odin Inspector > Preferences > Serialization > Editor Serialization Format.

3). ....


4). Unity: 5.6.5f1. 5). Version: 1.0.6.3. 6). Is the Editor Only Mode Window, meant to be just Name? Same with tab under it and General.

8). Windows 8.1

None of them types seem to be working. Fresh Project same.

Comments (17)

  1. John

    Anonymous Is me. General and Editor Only Mode and Persistent Context Cache, are blank with just the Name slot at the top. I Need to add this is with the .dlls. And none of the dropdown menus work, even in the examples, they don't open.

    I have deleted the .dlls now and unzipped the source files and its now working.

  2. John

    Im using the "Source" now, as that works. never had this problem. "Unitys Assembly Updater" is the one that is meant to run automatically? And can manually be ran from "Assets/Run API Updater".

    I tried unticking the .dll platform and reticking it and pressing apply.

    Also OdinUpgrader.cs file does not install, if that means anything. Can't get it to import.

  3. Bjarke Elias

    Interesting, are there any errors in the console? If it can't compile then it makes sense that OdinUpgrader wouldn't run. If you have a project where the OdinUpgrader exist, and isn't deleted I would love to take a look to see what's going on.

    Usually, what happens it that you Import Odin, and this dialog popup up: https://docs.unity3d.com/Manual/APIUpdater.html which you then need to press "Go Ahead" to.

    After that, it'll compile, a couple of times, and when its all done, the OdinUpgrader.cs should have deleted itself, and everything should bee good.

  4. John

    New Project, Imported from the AssetStore. This is after its finished importing and thats in the console. Not deleted the file.

    Don't have the file, won't import.

    A meta data file (.meta) exists but its asset 'Assets/Plugins/Sirenix/Odin Inspector/Scripts/Editor/OdinUpgrader.cs' can't be found. When moving or deleting files outside of Unity, please ensure that the corresponding .meta file is moved or deleted along with it. UnityEditor.AssetDatabase:Refresh() Sirenix.OdinInspector.Internal.OdinUpgrader:DeleteDirsAndFiles(List1, List1) (at Assets/Plugins/Sirenix/Odin Inspector/Scripts/Editor/OdinUpgrader.cs:134) Sirenix.OdinInspector.Internal.OdinUpgrader:Upgrade() (at Assets/Plugins/Sirenix/Odin Inspector/Scripts/Editor/OdinUpgrader.cs:80) Sirenix.OdinInspector.Internal.OdinUpgrader:Update() (at Assets/Plugins/Sirenix/Odin Inspector/Scripts/Editor/OdinUpgrader.cs:45) Sirenix.OdinInspector.Editor.<>cDisplayClass5_0:<DelayAction>b4() (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Config/UnityEditorEventUtility.cs:66) Sirenix.OdinInspector.Editor.<>cDisplayClass5_0:<DelayAction>b1(Int32, Rect) (at D:/Sirenix/Sirenix Solution/Sirenix.OdinInspector.Editor/Config/UnityEditorEventUtility.cs:56) UnityEditor.DockArea:OnGUI()

  5. Bjarke Elias

    Can't reproduce :(, It's a long-shot, but maybe try and open Unity with administrator right? Works for me with your Unity version, both on Win 7 and Win 10. Could you send me the broken project to bjarke@sirenix.net?

  6. GJ Roelofs

    Can confirm this behavior for 5.5.4f1 as well (Windows 10). OdinUpgrader has run (given that the pdb files are deleted).

    I've tried a clean install & install as admin. Source unzip seems to be the only workaround.

    Most preference pages are blank as well.

  7. NavidK0

    I also have the same issue on Unity 2018.1.0b13 on a new project straight from the New Project option. Deleting the Assemblies folder and unzipping the source.zip fixes the issue.

    The version of Odin used is 1.0.6.0 from the Asset Store, and I'm using Windows 10.

    This is what you see with Assemblies only: https://i.imgur.com/hX5Mxxw.png

    Same thing for the Editor Only and Persistent Context Cache.

  8. Bjarke Elias

    Man this is strange.

    @John thanks for the project, unfortunately, it jokred perfectly on my machine in multiple version of Unity.

    @NavidK0 Extra strange that you get similar behavior in 2018, what is going on here.

    Could any of you share a screenshot of the Sirenix.OdinInspector.Editor.dll? I'm curious to know whether it correctly identifies all UnityTypes.

    Here is how mine look: https://jumpshare.com/v/UQXieiBDtOSOB8NUfXuN

    Also, try and do a "Window > Revert Factory Setting", I've heard romers that some have fixed custom editor related issues before.

  9. Bjarke Elias

    Hey everyone here.

    NavidK0 helped me a tremendously amount on Discord yesterday, getting to the bottom of why things worked in source-code mode and not with an assembly. And we finally managed to reproduce the issue consistently on my machine.

    Turns out we had a bug, in the way we got the location of an assembly, which would give the wrong path in some cases, which caused all sort of weird things to happen.

    If the path to your project, contains any folders with non-letter-or-digit characters in them, then it'll likely cause issues. That bug is fixed now, and will be submitting it to the Asset-Store which usually takes a couple of days to be approved.

    Would love to know whether this also has solved other issues reported in this thread. If you're willing to send me a mail at bjarke@sirenix.net with your Odin invoice ID incldued, then I'll send you the hot fix right away and we can see if it has fixed other cases as well.

  10. Bjarke Elias

    Thanks for the patience and help. John / OP, confirmed that the hot-fix solved his issue as well. So this is fixed as of 1.0.6.5, which is now submitted to the Asset Store.

  11. Log in to comment