Missing references show as 'None' in Editor

Issue #693 new
pistoleta created an issue

Unity v 2019.4.9f1
Catalina OSX
Odin v 2.1.12
NOT using Editor only mode.

When using Odin, editor doesnt set the 'Missing' reference status on any lost reference. I tried with different components, and I tried on simple monoBehaviours, but when the reference is lost, (destroying the object or removing the component) the status is always set to None.

Tried creating a new project without Odin imported, and this happened:
1st: I create MyScript MonoBehaviour with different references

2. This is what happens when I remove the different references. Marked ‘Missing’ as expected.

3. And this is what happens inmediatly when I import Odin to the project.

This is somehow important for us because we are using an asset called Mantainer which finds missing references and seems right now is not able to find them. I asked the asset developer how does he find them just in case it might be use for you guys:

“the asset finds serialized properties which objectReferenceValue is null while objectReferenceInstanceIDValue is not 0 which means instanceID reference is still present but actual object is missing, this is a missing reference.”

Thanks a lot for your great support.
pistoleta.

Comments (2)

  1. pistoleta reporter

    any comments on this ? is it happening on other versions? some feedback would be appreciated, thanks a lot.

  2. Log in to comment