Odin Inspector and Serializor V1.0.0.2

Issue #82 resolved
Former user created an issue


I finally got it to work by completely deleting the Odin project and re-importing it. I had 2 issues with it. one was that it was upgraded from v1.0.0.2 to v1.0.0.3. Unity didn't seem to like that.

The second issue is the one below. the first time I ran the project, it wouldn't render anything. i figured it out. It was an issue that I had a script named "Spawner" and Odin also had a script named "Spawner". this seemed to cause conflicts, so i renamed myscript instead. (Both issues are resolved in my project, just thought you might want to keep this for reference)

I found an issue with ODIN Inspector and Serializor. Whenever I run the project, it doesn't render the inspector on open to my project, and I get the following Error: UntilYouDie\Temp\CodeGeneration-e1aa7a62-7f59-45c0-86cb-35e61bb62968\Drawers.cs(446,25): error CS0101: The namespace Sirenix.OdinInspector.GeneratedEditors' already contains a definition forSpawner_Editor' UnityEngine.Debug:LogError(Object) Sirenix.Utilities.Editor.CodeGeneration.AssemblyGenerator:Compile(String, Boolean) (at C:/Users/Bjarke/Desktop/Projects/Sirenix Development Framework/Sirenix Solution/Sirenix.Utilities.Editor/Code Generation/AssemblyGenerator.cs:374) Sirenix.OdinInspector.Editor.EditorCompilation:CompileEditors(TypeDrawerPair[]) (at C:/Users/Bjarke/Desktop/Projects/Sirenix Development Framework/Sirenix Solution/Sirenix.OdinInspector.Editor/Misc/EditorCompilation.cs:396) Sirenix.OdinInspector.Editor.EditorCompilation:TriggerAutomaticRecompile(TypeDrawerPair[]) (at C:/Users/Bjarke/Desktop/Projects/Sirenix Development Framework/Sirenix Solution/Sirenix.OdinInspector.Editor/Misc/EditorCompilation.cs:299) Sirenix.OdinInspector.Editor.EditorCompilation:RecompileAsSoonAsPossibleIfEditorsChanged() (at C:/Users/Bjarke/Desktop/Projects/Sirenix Development Framework/Sirenix Solution/Sirenix.OdinInspector.Editor/Misc/EditorCompilation.cs:247) UnityEditor.EditorApplication:Internal_CallUpdateFunctions() I also get 2 generated docs that cause issues w/ it as well in side the temp files. Trying a variety of things to get this working, no luck so far.

Comments (1)

  1. Tor Esa Vestergaard

    This bug (and many others) have been resolved in the newest patch of Odin, which should be hitting the asset store any time now.

  2. Log in to comment