Cannot install rubygems 0.2.0

Create issue
Issue #6 resolved
Kim Chee Leong created an issue

When I try to install the latest rubygems (0.2.0) I am getting an error in buildout.

Installing rubygems.
While:
  Installing rubygems.

An internal error occurred due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
  File "/Users/leong/.buildout/eggs/zc.buildout-2.2.0-py2.7.egg/zc/buildout/buildout.py", line 1942, in main
    getattr(buildout, command)(args)
  File "/Users/leong/.buildout/eggs/zc.buildout-2.2.0-py2.7.egg/zc/buildout/buildout.py", line 622, in install
    installed_files = self[part]._call(recipe.install)
  File "/Users/leong/.buildout/eggs/zc.buildout-2.2.0-py2.7.egg/zc/buildout/buildout.py", line 1366, in _call
    return f()
  File "/Users/leong/.buildout/eggs/rubygemsrecipe-0.2.0-py2.7.egg/rubygems.py", line 241, in install
    self._install_rubygems()
  File "/Users/leong/.buildout/eggs/rubygemsrecipe-0.2.0-py2.7.egg/rubygems.py", line 139, in _install_rubygems
    url, version = self._get_latest_rubygems()
  File "/Users/leong/.buildout/eggs/rubygemsrecipe-0.2.0-py2.7.egg/rubygems.py", line 126, in _get_latest_rubygems
    s = str(s)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 1577: ordinal not in range(128)

Comments (3)

  1. Log in to comment