Issue #1759 resolved

Bitbucket doesn't accept my uploaded photo

Bastian Doetsch
created an issue

... and there's no option to remove an uploaded foto so it uses gravatar :). Find attached the image that I can't activate...

Comments (30)

  1. Bastian Doetsch reporter
    • changed status to new

    If you try to open the image directly the following error is shown (I tried again, with a different pic, therefore the different pic name):

    URL: https://bitbucket-assetroot.s3.amazonaws.com/c/photos/2010/Mar/11/profile_pic_35x_avatar.jpg

    <Error>
    <Code>NoSuchKey</Code>
    <Message>The specified key does not exist.</Message>
    <Key>c/photos/2010/Mar/11/profile_pic_35x_avatar.jpg</Key>
    <RequestId>8F714171521FACDC</RequestId>
    −
    <HostId>
    gFAT04I+vGqPuFybu9WL7MB1xG+448eka+p1+Hpp9GGSkmGh8yjzauqeyRLJX0Q1
    </HostId>
    </Error>
    
  2. Bastian Doetsch reporter

    (Reply via bas...@gmx.de):

    Hi Jesper, for me it still doesnt work:

    <Error> <Code>NoSuchKey</Code> <Message>The specified key does not exist.</Message> <Key>c/photos/2010/Mar/12/profile_pic_48x_avatar.jpg</Key> <RequestId>B5DD52DAD8B4CDB8</RequestId>

    E2=88=92

    <HostId> LkP3/dYia2M25lzA7Q6t8/yjOor/Ql7X+seEI6Wj209td4+LXO7901UDimbPXK2V </HostId> </Error>

    2010/3/12 <issues-noreply@bitbucket.org>

  3. Justin Chester

    I tried uploading an image, and it worked initially, but now nothing is displayed. I tried resizing the image up from 32x32 to 35x35 and I tried switching to a different format (from PNG to JPG) but nothing worked. All I have now is the empty box, which just looks sad :(

    Trying to view my image directly yields the following error:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.

    <Error>
    <Code>NoSuchKey</Code>
    <Message>The specified key does not exist.</Message>
    <Key>c/photos/2010/Mar/16/Bass-icon_avatar.jpg</Key>
    <RequestId>AB67EFC6F322D1C4</RequestId><HostId>
    bqhDgoNCoGrDouGkMMS3B7/snjJZ1Ke1XgwTvgAGTjqMvoziHLUOIfLBCVSVvtQl
    </HostId>
    </Error>
    
  4. Eirik Stavem

    Sorry about this guys, until we get a fix in place, just email support@bitbucket.org and give us your username so we can remove your avatar, and you can optionally fall back to gravatar.

  5. Dries Desmet

    I can confirm Raffele's finding. I uploaded an image 120x120 and it started working. The garbled pixels I had with that image when I tried this last week (a scaling issue) have disappeared. I retried my 35x35 images and that still doesn't work.

  6. Luís Brás

    I, too, confirm Raffaele's workaround. Finally my repository has a logo :-). I tried with a 36x36 and 100x100, but to no avail. Only a 200x200 jpg did the trick.

  7. David Chambers

    I've tried images of different sizes — including the "magical" 200x200 — without success. I haven't managed to get an image to appear at all. I've tried different file formats, too. :(

  8. dr0id

    An 35x35 pixel png without compression (made with gmip) worked for me. First I tryed other png's with compression but they didn't work, maybe it is a problem with compression?

  9. Log in to comment