Issue #3131 resolved

Can't change wiki from private to public when accessed via a CNAME (BB-2860)

Diego Calero
created an issue

I'm not beeing able to change the repo wiki from private to public in the admin. There is no submit button, so the form can never be sent.

Thanks in advance for this excellent service!

Comments (6)

  1. Dylan Etkin

    Hi Diego,

    What browser are you using?

    When you click the radio button the change is immediately sent to the server.

    You should see a spinner and then a green check once the operation has been completed.

    We support Chrome, Safari 5, Firefox 5, 6 & 7, IE 8 & 9.

    Cheers,

    Dylan

  2. Diego Calero reporter

    Hello Dylan, first of all thanks for your reply!

    I'm using FF 7, but I checked with Firebug and the issue is with the URL where the form is sent.

    I use a CNAME to my account (hg.diegocalero.com), so when I click the "Public wiki" radio the form is sent to: http://hg.diegocalero.com/di3g0/--repo--/admin/wiki resulting in a 404 (since it should be http://hg.diegocalero.com/--repo--/admin/wiki )

    This issue happens when I change the "Repository details" too. The form is saved OK but I get redirected to a 404 ( http://hg.diegocalero.com/di3g0/--repo--/admin )

    That's all, easy to solve ;)

    Many thanks, Diego.

  3. Dylan Etkin
    • changed status to new

    Hi Diego,

    Thanks for the clarification. For now please change those settings by accessing the repo from the bitbucket.org url.

    We will look into fixing this for CNAME's.

    Cheers,

    Dylan

  4. Log in to comment