Issue #3849 duplicate

A Bug For Create Issue (BB-4015)

bearzx
created an issue

When I created a issue just now, I forgot to set the "Assign to" and "Component" part, then after I clicked the "Report issue", it took a long time to load the new page and finally failed. After I enter my homepage, I' ve found that there are lots of status for my creation of that issue, like "You are no longer following this issue.", "You are now following this issue.", on and on. And what's more, I can never open that issue because when I do this, the page crashed. Wish this can be solved.

Comments (6)

  1. Brian Nguyen staff
    • changed status to open

    Hi,

    Thanks for reporting this.

    Could you tell us for what repository and issue you saw this problem on? It will give us a better understanding of the problem.

    Cheers, Brian

  2. bearzx reporter

    Hi, This is the repo where I found the bug:

    https://bitbucket.org/dzy0451/hoj/issues

    And the issues which have bug is issue #7 and #8.

    And now I have kind of figured out what is happening when I tried to create a issue on my repo. Here is the thing: When I tried to create a new issue, I put a word "follow" in the title of the issue, and after I clicked the "report issue" button, bitbucket create a link to this issue, in this situation, it is:

    https://bitbucket.org/dzy0451/hoj/issue/8/follow

    And by coincidence there is an API whose function is to follow a issue, so a conflict has come. When I tried to open my issue page, I found my browser keep requesting the server many times, finally became a "This webpage has a redirect loop" error.

    So the problem is the name conflict, change the issue name may help, but I even can' t open my issue page now. Or we can change the API name, but may be a lot of work to fix other parts which uses the "follow" API.

    Wish these information would help.

    cheers~

  3. Log in to comment