Issue #4570 resolved

remote: conq: invalid command syntax.

Maciej Maciaszek
created an issue

I'm getting remote: conq: invalid command syntax when I try to pusth to bitbucket mercurial repository.

I haven't got this before...

Mercurial Distributed SCM (version 2.3) (installed with HomeBrew on MacOS 1.8.1)

Comments (16)

  1. Alex Martelli

    I'm getting exactly the same problem as Maciej (in my case what I'm trying to do is hg clone a repo that my wife just successfully created). I'm using version 1.7.1+20101116 -- do I need to upgrade...?

  2. Isaac Turner

    I'm getting this too:

    % hg pull bits --debug
    running ssh hg@bitbucket.org '/home/turner/bin/hg -R isaacturner/repo serve --stdio'
    sending hello command
    sending between command
    remote: conq: invalid command syntax.
    abort: no suitable response from remote hg!
    
  3. Marcus Bertrand staff

    For those not running the latest Mercurial, please upgrade, it usually fixes unusual authentication issues. For the OP, please open a support request directly with all of your URL's and details and we'll get you sorted out. Support email is support@bitbucket.org

  4. Marcus Bertrand staff

    For those not running the latest Mercurial, please upgrade, it usually fixes unusual authentication issues. For the OP, please open a support request directly with all of your URL's and details and we'll get you sorted out. Support email is support@bitbucket.org

  5. Erik van Zijst staff

    Correct.

    Using --debug nicely reveals the command that your local hg process tries to execute on our servers. In Isaac's case, that is /home/turner/bin/hg which obviously does not exist on our end, leading to the "invalid command" error that you see printed.

  6. Robert Wallis

    Just +1, had the same problem, and in my ~/.hgrc [ui] remotecmd was specifically set because of another server having problems finding the executable in the path.

    So I resolved it by removing the remotecmd from my global .hgrc, thanks Erik

  7. Log in to comment