Issue #606 invalid

Can't use downloaded tortoise-0.7.3-hg-1.2.1.exe

Anonymous created an issue

It says "the setup are corrupted". (tried with firefox and wget on Windows XP)

Comments (2)

  1. Log in to comment