Issue #7558 resolved

[wiki] number in anchor parsed as issue reference (BB-8725)

Tom Roche
created an issue

I have a wiki page which cites a URI with an anchor beginning with the numeral '12':

References:

* [[http://edgar.jrc.ec.europa.eu/index.php|EDGAR homepage]]
* [[http://edgar.jrc.ec.europa.eu/overview.php?v=42|EDGAR-4.2 overview]]
* [[http://edgar.jrc.ec.europa.eu/methodology.php#12sou|EDGAR-4.2 categories]]
* [[https://bitbucket.org/tlroche/edgar-4.2_minus_soil_and_biomass_to_aqmeii-na|my project for assimilating non-agricultural-soil EDGAR inventories]]

Unfortunately, your parser appears to be attempting to render this as a reference to a bitbucket issue:

References:</p>
<ul><li><a href="http://edgar.jrc.ec.europa.eu/index.php">EDGAR homepage</a>
</li><li><a href="http://edgar.jrc.ec.europa.eu/overview.php?v=42">EDGAR-4.2 overview</a>
</li><li><a href="/tlroche/aqmeii-na_n2o/wiki/http://edgar.jrc.ec.europa.eu/methodology.php%3C%3Cissue%2012%3E%3Esou">EDGAR-4.2 categories</a>
</li><li><a href="https://bitbucket.org/tlroche/edgar-4.2_minus_soil_and_biomass_to_aqmeii-na">my project for assimilating non-agricultural-soil EDGAR inventories</a>
</li></ul>

I.e., the markup link

[[http://edgar.jrc.ec.europa.eu/methodology.php#12sou|EDGAR-4.2 categories]]

should render as

<a href="http://edgar.jrc.ec.europa.eu/methodology.php#12sou">EDGAR-4.2 categories</a>

but is instead rendering as

<a href="/tlroche/aqmeii-na_n2o/wiki/http://edgar.jrc.ec.europa.eu/methodology.php%3C%3Cissue%2012%3E%3Esou">EDGAR-4.2 categories</a>

Please fix.

Comments (2)

  1. Log in to comment