Issue #9494 open

Long Repo Names : Unable to Change Repo Logo from Default (BB-10600)

Ellery McKenzie
created an issue

I created a repo on 2014-05-14.

I have attempted to assign a logo to the repo a number of times over the last several days with no joy. The default logo stubbornly refuses to go away:

Untitled 2.png

  • I click on Change Logo and select a new logo
  • I then click on Done and I get the "updating" animation:

Untitled 3.png

After that, nothing changes. Clicking on Save Repository Details has no effect (per: https://bitbucket.org/site/master/issue/5286/impossible-to-change-projectlogo). The default logo remains in place, both in the repo settings and any page that shows the repo logo (like our team page).

Doing a full page reload or logging in from a completely different computer has no effect.

I have not hit this issue in any of my previous repos (the latest one being created on 2014-03-25).

I have tested on Firefox/osx, Chromium/osx, Safari/osx and Firefox/linux. Same effects in every case.

Update

It seems that having a really long repo name may be the cause of this problem. I'll update further with some steps to reproduce the issue sometime soon.

Comments (9)

  1. Ellery McKenzie reporter

    With some testing I found that the length of the repo name seems to be invovled with the problem somehow. I've shorted the name and it's working for now.

  2. Ellery McKenzie reporter

    also note that there is a ">" in the title. I wonder if that's being expanded into ">" or "%62". That would push the title length beyond 64 characters. I wonder if that may have something to do with it ?

  3. Log in to comment