Issue #9631 invalid

OMPL install. CCX compiler not found

Jo So
created an issue

I have followed the instructions on the OMPL website and installed all the packages required for the OMPLapp. I am a complete noob when it comes to Linux Ubuntu. I run the cmake ../.. command and I get this. I have Python 2.7.6 installed.

jordan@ubuntu:~/Desktop/omplapp-0.14.2-Source/build/Release$ cmake ../.. -- The CXX compiler identification is unknown CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name. -- Building RelWithDebInfo -- Boost version: 1.54.0 -- Found the following Boost libraries: -- date_time -- thread -- serialization -- filesystem -- system -- program_options -- unit_test_framework -- chrono -- Boost version: 1.54.0 -- Found the following Boost libraries: -- python -- checking for module 'ccd>=2.0' -- package 'ccd>=2.0' not found -- checking for module 'fcl>=0.3.1' -- package 'fcl>=0.3.1' not found -- CCD library not found. Will download and compile. -- FCL library not found. Will download and compile. -- checking for module 'assimp' -- found assimp, version 3.0.1264 -- Boost version: 1.54.0 -- Found the following Boost libraries: -- python -- Boost version: 1.54.0 -- Found the following Boost libraries: -- python -- Configuring incomplete, errors occurred! See also "/home/jordan/Desktop/omplapp-0.14.2-Source/build/Release/CMakeFiles/CMakeOutput.log". See also "/home/jordan/Desktop/omplapp-0.14.2-Source/build/Release/CMakeFiles/CMakeError.log".

As far as I can tell I have the compiler present in the cmake folder in the Release folder. I have also downloaded cmake-2.8.12.2 from the cmake website but this seems redundant to the 2.8.12.2 folder that came with OMPL. Also, I'm not sure if the CCD and FCL libraries that are not being found are related to the missing compiler.

Any help would be spectacular. I real want to get started with the GUI.

Thanks.

Comments (1)

  1. Log in to comment