1. Bitbucket
  2. Public Issue Tracker
  3. master
  4. Issues

Issues

Issue #10024 resolved

Abandoned transaction found - run hg recover! teamcity 7.1

Bill Hamawi
created an issue

Hi. I'm using TeamCity 7.1, I keep getting an error about being unable to pull changes from BitBucket today so I'm currently unable to build and deploy. Which is causing us major problems in the office.

This is in the logs: "abandoned transaction found - run hg recover!".

The repository: https://bitbucket.org/plutora/portal

Please can you resolve this for me!!!! as it is a pressing issue.

Comments (4)

  1. Bill Hamawi reporter

    I ran it locally and it does not fix the issue. We received the message "no interrupted transaction available."

    There must be something you can do as we have tried everything we could research.

  2. Kaleb Elwert

    Please try running hg recover on your build server, similar to the other issue. If that doesn't work, please feel free to email support@bitbucket.org. They should be able to help you.

  3. Log in to comment