Issue #10168 resolved

Importing From SourceForge (using Sourceforge and GIT imports) and delete failed repro's

Richard Lukins
created an issue

Was trying to import a couple of projects from SourceForge and both gave errors in the setup screen. I finally worked out how to get one of them correctly "described" in the import panel not to give errors but not the other.

Maybe for "newbies" like me some extra help and examples would be good, as I'd have not tried to hit import with the error showing for 1 project had I not found this thread. But clearly the error is either wrong or should be a more explicit "warning" as the settings worked !? But also led to a failed attempt I cannot delete!

an example using the SourceForge command line translating to fields would be good!! ie

svn checkout svn:// web-erp-code

showing: Project name = web-erp (the FIRST bit after "svn://" ) Mount point = code/trunk (the bit after the Project name without a leading "\") would have saved me loads of time and frustration !!

However I now have a repository called "web-erp" that failed due to the wrong settings and cannot delete it !! any help on this?

For the other SourceForge Project I was able to import but with a "No repository exists at that URL" message, but it seemed to work and come across.

the sourceforge pull was hg clone frontaccounting-mercurial

It appeared to work using: Project - frontaccounting Mount - mercurial and using mercurial as the type but not sure if this is going to fail later in life ?! How important is the error?

Being no pro at this, I'm a little disappointed by the lack of help, explanations or examples ... indeed the error itself is vastly unhelpful !!

Sadly, so much for simplicity, tried the above format for SuiteCRM

git clone git:// suitecrm-code

using project "suitecrm" Mount "code", but despite the HTTP looking just like the Sourceforge example it refused to find the project and ignoring the error created another dead and undeleteable project.

Used the GIT import and it worked fine ... apart from the project is showing as empty?!

What am I doing wrong with the SuiteCRM import! help, frustrated!! cheers Richard

Comments (4)

  1. Richard Lukins reporter
    • changed status to open

    This is not fixed. The FrontAccounting import still gives an error during the check phase, yet imports ok. This is a bug. The SuiteCRM still fails to import. I still have 2 failed repro's that I cannot delete and despite asking elsewhere, remain at large! (Web-erp and SuiteCRM - please delete!! or tell me how)

    A bit strange to set to resolved without asking first? Why would you think it is fixed?

  2. Log in to comment