Stuck on "Please wait, your repository is being created now..."

Issue #10460 resolved
Junaid Younus
created an issue

Hey there,

SourceTree 2 for Mac - when trying to create a private remote repository for an existing local repo, I get the following message and nothing happens after that (even after a few minutes). No updates on my BitBucket account either.

"Please wait, your repository is being created now...".

I should also mention that pressing the "Cancel" button doesn't do anything. It's just stuck on that screen.

Official response

Comments (72)

  1. Peter Curtis

    Basically the same problem on Yosemite with the latest version of SourceTree. Hangs in definitely on creating the repository, and certainly never creates it.

    The cancel button now works for me, but come on; integration with Bitbucket is pretty much SourceTree's raison d'être.

  2. John Garcia

    I just double-checked to be sure, and the whole process worked great for me. Would anyone be interested in filing a support issue so we can verify this behavior?

  3. krejd

    Not working for me too. Hangs on "Please wait, your repository is being created now..." and never finishes. Does not freeze, I can still hit "Cancel" button.

  4. Charles Mousseau

    I had this exact problem. The name of my repository was "C++", and when I created one manually on the remote server and tried to clone it, it suggested the name "c.git"; this led me to believe it was the non-alphanumeric characters in the name "C++". Created a new repository named "CPlusPlus" and it worked perfectly.

  5. Tim Osborn

    stuck on: "Please wait your repository is being created" can't click cancel, must force quit. repo was not created: had to use the BB web interface

    steps: - in existing local repo, click settings>remotes>add - click the 'globe' icon - click 'Create new Reopsitory' - fill in the form: Name, git, private <hang>

    how is this issue 'invalid'?

    OSX 10.10.3, Sourcetree 2.0.5.2

  6. Gabe Chavez

    I'm having this problem with SourceTree for OSX as well. My repo name contains no whitespace and consists of alphanumeric characters only.

    Update: I was able to create a new remote on Github without issue. Sorry about that Atlassian, but if you can't be bothered to fix your products, I guess that's good for your competition.

  7. Antanas Domarkas

    Had same issue on OSX 10.10.4 / SourceTree 2.0.5.2

    Here's console output:

    2015-08-20 16:47:12,249 SourceTree[17377]: -[__NSDictionaryM dataUsingEncoding:]: unrecognized selector sent to instance 0x60800044e130
    2015-08-20 16:47:12,249 SourceTree[17377]: -[__NSDictionaryM dataUsingEncoding:]: unrecognized selector sent to instance 0x60800044e130
    2015-08-20 16:47:12,250 SourceTree[17377]: (
        0   CoreFoundation                      0x00007fff8f03003c __exceptionPreprocess + 172
        1   libobjc.A.dylib                     0x00007fff90db876e objc_exception_throw + 43
        2   CoreFoundation                      0x00007fff8f0330ad -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
        3   CoreFoundation                      0x00007fff8ef78e24 ___forwarding___ + 1028
        4   CoreFoundation                      0x00007fff8ef78998 _CF_forwarding_prep_0 + 120
        5   SourceTree                          0x0000000108435960 SourceTree + 1403232
        6   SourceTree                          0x000000010842fff6 SourceTree + 1380342
        7   Foundation                          0x00007fff92cc7d00 __NSThreadPerformPerform + 293
        8   CoreFoundation                      0x00007fff8ef4ca01 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
        9   CoreFoundation                      0x00007fff8ef3eb8d __CFRunLoopDoSources0 + 269
        10  CoreFoundation                      0x00007fff8ef3e1bf __CFRunLoopRun + 927
        11  CoreFoundation                      0x00007fff8ef3dbd8 CFRunLoopRunSpecific + 296
        12  HIToolbox                           0x00007fff8734b56f RunCurrentEventLoopInMode + 235
        13  HIToolbox                           0x00007fff8734b2ea ReceiveNextEventCommon + 431
        14  HIToolbox                           0x00007fff8734b12b _BlockUntilNextEventMatchingListInModeWithFilter + 71
        15  AppKit                              0x00007fff8b8f88ab _DPSNextEvent + 978
        16  AppKit                              0x00007fff8b8f7e58 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 346
        17  AppKit                              0x00007fff8b8edaf3 -[NSApplication run] + 594
        18  AppKit                              0x00007fff8b86a244 NSApplicationMain + 1832
        19  SourceTree                          0x00000001082e1034 SourceTree + 8244
        20  ???                                 0x0000000000000001 0x0 + 1
    )
    
  8. Steve Woodall

    Yes, on the latest release. I am using hypens in the name but that is our naming convention which works via a browser. Although not using hypens el al is a work-arround its not a fix.

  9. Josh Buchea

    I was experiencing this yesterday. Frustrating experience indeed. Ended up having to create local in SourceTree, create remote in website, and manually add remote in SourceTree.

  10. Carlos Mas

    Hello,

    I have the same issue. I expend almont 30 min creating folders and trying to sync with bitbucket, then i found a workaround. hope will help someone.

    I Try to create a repository on the web, sync to sourceTree to an empty folder and then add all the data to that folder and push.

    works for me.

  11. Mark Hall

    Same bug here. Removed hypens, still just hangs although it does make the repository remotely.

    Just doesn't copy the files.

    Edit: Scrap that, I got it working. I went back and started my repositories from scratch and it worked. I initialised the folder containing the repository folders, not each repository individually. Whoops.

  12. Stefan Badea

    If I remember correctly I got it fixed by cleaning the user dropdown. I had my name in there like 4 5 times. I am not sure where/how I did it but when I had only one username to select from it worked.

  13. Oliver Schöndorfer

    And the same Issue. Has there no solution been found yet?

    Same thing when I want to create a remote repository from the app. Just freezes.

    Using Source Tree Version 2.2 (46) OSX El Capitan 10.11.3 (15D21)

    My workaround was creating a new remote repository (empty). Then after I forced the frozen Sourcetree app to restart I cloned that repository to my computer, put the files in and committed those.

  14. Dominic Tracey

    It seems to be a permission error - when I try to use the command line I get:

    Permission denied (publickey). fatal: Could not read from remote repository.

    I log on with a google account so I assume it has to do with the google ssh key missing on my local machine. I got it to work by connecting to the remote repo (bitbucket) with HTTPS instead of SSH.

  15. Jürgen Simon

    I hit the same issue. It's damned annoying. When you do push the content from command line using mercurial, it also does not add the remote, which created yet another step that you have to do manually. It also pops up when you simply add the remote repository, add your files, commit and then try to 'publish to remote repository'. This is the stack trace I am getting every time in Console.app:

    31/08/16 13:01:15,287 SourceTree[9470]: (
        0   CoreFoundation                      0x00007fff8508925c __exceptionPreprocess + 172
        1   libobjc.A.dylib                     0x00007fff83340e75 objc_exception_throw + 43
        2   CoreFoundation                      0x00007fff8508c12d -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
        3   CoreFoundation                      0x00007fff84fe7272 ___forwarding___ + 1010
        4   CoreFoundation                      0x00007fff84fe6df8 _CF_forwarding_prep_0 + 120
        5   SourceTree                          0x000000010a6be2d5 SourceTree + 1131221
        6   Foundation                          0x00007fff8453b75e __NSThreadPerformPerform + 229
        7   CoreFoundation                      0x00007fff84fba5b1 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
        8   CoreFoundation                      0x00007fff84fabc62 __CFRunLoopDoSources0 + 242
        9   CoreFoundation                      0x00007fff84fab3ef __CFRunLoopRun + 831
        10  CoreFoundation                      0x00007fff84faae75 CFRunLoopRunSpecific + 309
        11  HIToolbox                           0x00007fff89823a0d RunCurrentEventLoopInMode + 226
        12  HIToolbox                           0x00007fff898237b7 ReceiveNextEventCommon + 479
        13  HIToolbox                           0x00007fff898235bc _BlockUntilNextEventMatchingListInModeWithFilter + 65
        14  AppKit                              0x00007fff8bb3624e _DPSNextEvent + 1434
        15  AppKit                              0x00007fff8bb3589b -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 122
        16  AppKit                              0x00007fff8bb2999c -[NSApplication run] + 553
        17  AppKit                              0x00007fff8bb14783 NSApplicationMain + 940
        18  libdyld.dylib                       0x00007fff87ce25fd start + 1
    )
    
  16. Hamid Javadi

    I got the same issue but when i had a look on the Error message i found this:

    "message: Invalid slug. Slugs must be lowercase, alphanumerical, and may also contain underscores, dashes, or dots."

    when i changed the Uppercase letters to lowercase the problem's solved.

  17. Burak Kurkcu

    I have the same problem. If you use lowercase it proceeds but not taking account "private repo" checkbox. It created public repo. So there is more than just naming issue.

  18. Steve Monro

    Ditto. And On Windows 1.10.20.1 "Invalid slug. Slugs must be lowercase, alphanumerical, and may also contain underscores, dashes, or dots." This is happening with or without spaces... While you are fixing this issue, how about a quick checkbox to automatically convert weird characters to underscores, or automatically remove spaces etc... :)

  19. Mad Baron

    Eka, I had the same issue, but I was fortunate enough to get the cancel button to work. The error message reminded me that remote repository slugs can only contain lowercase character. I changed the case and the remote repository was added with no problems.

    Sourcetree devs should check slug case on the front end rather than the back end.

  20. Serj Rubens

    still have this issue. cant create a remote repo + app every time proposing me to signin. in settings i have an oAuth authorization and everything looks perfect with login

    sourcetree version is Version 2.4.1 (97) mac OS version 10.12.3

    UPDATE: i didn't get that the name (you naming it slug, ok :) ) of repo must start from and probably have only lowercase symbols

  21. Hossein Miri

    I am still getting the "message: Invalid slug. Slugs must be lowercase, alphanumerical, and may also contain underscores, dashes, or dots." error message with SourceTree version 2.5 on Mac OS version 10.12.4

  22. Hossein Miri

    @ Serj Ruben Yes, it did initially. Still would not create it. Though when I went through the site, I was actually able to create a repo beginning with a capital letter (Unity) so eventually I managed to create it somehow!

  23. Log in to comment