Removing myself from a different user's private repository

Issue #10466 duplicate
Prasanna Loganathar
created an issue

Hi,

There seems to be no option to remove oneself from a private repo, if one is not an administrator of it, since non-admins don't have access to user management.

I'd like myself to be removed from a repository owned by someone else. Please let me know how to go about it. Contacting the admin of the repo to do a self clean up of my personal following repos seems to be a tedious task, if this has to be done every-time.

Regards, PVL

Official response

  • Alastair Wilkes staff

    Hi y'all,

    The revoke button on the repository overview page or leave team button on the team profile should cover most cases. However, if you have access via a group and don't want to leave the team (or if the group is owned by an individual account), there's no recourse - so we recently reopened #454 to cover these cases.

    In the meantime, if the revoke button on the repository overview page or leave team button on the team profile page doesn't show up for you, contact support, and we'll help get you sorted.

    Thanks,
    Alastair

Comments (82)

  1. Prasanna Loganathar reporter

    This is a very simple issue, that involves unnecessary tedious tasks. Please add an option to do so. As a user, the user should always have right to decide which repo he/she should be a part of. Repository owner can only "permit".

    Being a part of a repository now, is like locking yourself up into a jail, where you will never be let out unless the jailer, at his leisure, wishes to.

  2. Gytis Škėma

    I own the orginal repo, but I also had to be invited to forked repos to be able to review PRs before merging (another bug too). Now that I no longer work with the forked repos, they still show up in other 3rd party tools, which make hard to recognize which one is the original. Ability to remove yourself should definitely be implmented

  3. santiontanon

    I find it outrageous that this is marked as "INVALID". This is a serious issue. In my case, The owner is basically not responding. So, am I trapped forever to navigate a list of repositories that are not the ones I will EVER use, each time I log in to bitbucket?

  4. alvaro

    As far as I know, there is no documented way to do so, but it exists support in the API. If you want to remove yourself from a repo managed by another user, just type in the browser command line https://bitbucket.org/xhr/repository_owner/repository_name/revoke (replace repository_owner and repository_name with appropriate values)

    This was posted in https://bitbucket.org/site/master/issues/454/ability-to-remove-yourself-from some time ago by Pavel Dvorkin (scroll down and you'll see the original response)

  5. João Saraiva

    When clicking the "revoke" link, I get a template for a message asking for my access revoke.

    When using the URL API trick, I get a "you do not have access to the repository" message.

    It's laughable that this problem has existed for years, would be really easy to solve (after all, the API is already there!), but apparently the devs have no interest in solving it.

  6. João Saraiva

    Just my 2c again. The problem is that the devs automatically consider this kind of issue as "solved" or "invalid".

    For example, look at issue https://bitbucket.org/site/master/issues/454/ability-to-remove-yourself-from , where the devs just used the "API revoke" URL trick and then said in another issue "if you're in the repository via a group instead of a team, then there's nothing you can do" ( https://bitbucket.org/site/master/issues/12497/can-not-revoke-write-access-to-a ). It's probably just a simple matter of removing a row from a database, for Pete's sake...

    Also, the "ask the repo admin to let me leave the repo, pretty please with a cherry on top" is very nice and all. However, what if you're leaving the repo for a dead project -- so the repo admin doesn't really care if you get any future code, because there won't be any future code --, and you are not in good terms with that same repo admin? In other words, what if you want to limit your interactions with him/her to no more than whatever is absolutely necessary? Personally, I consider a request to leave a repository to be outside of the "strictly necessary" zone...

  7. Nathan Westlake

    Wow. It's pretty disappointing this is considered "invalid". Quite valid to want to remove yourself and not waste your time and someone else's time explaining to them what to do.

  8. C Beattie

    Invalid because you already can do it? Overview tab lists your access rights, next to that is a revoke link. Click the link and get a pop up asking if are sure you want to remove YOUR rights to this repo. Press yes and TA DA no more repo.

  9. João Saraiva
  10. Alastair Wilkes staff

    There's currently a bug with revoking your own access if your access is granted via a group permission. We are working on resolving this. At this time, the best workaround is to contact the admin of the repo to remove you from the group.

    However, if your access has been granted directly, 'revoke' should work.

  11. TechTrip

    This issue has been requested for years yet the atlassian response is still pretty much the same. It's not that hard to comprehend. You were added to somebody's private repo. You no longer want to have those repos show up in your list which forces you to ask somebody else to remove you which is backwards. I've searched everywhere for the "revoke" button. So pretty much wasted 30 minutes trying to figure out something that should have been one of the first features added to this interface.

    Yet one more reason to look for alternatives.

  12. Lefthandmedia

    No thats no help at all. I think you don't understand the point. In your '/dashboard/repositories' there are all repositories (not projects) your somehow connected to. I want to remove some of those repo's fromt my dashboard. the ones that aren't mine, that are abandoned or a i can't reach the owner or whatever reason.

    There is NO revoke button on a repo believe me. i've search vigorously.

  13. Radomir Đurđević

    I confirm comments from @Lefthandmedia and @joão Saraiva. THERE IS NO OPTION TO GET OUT OF THE HELL OF SEEING NEWEST COMMITS ON THE OUTDATED PROJECT I DONT PARTICIPATE IN ANYMORE. Come on Atlassian, this was funny, then sad, then it started being embarrassing. I don't know where does it leaves us now. Act!

    No I can't or don't want to contact the admin of the old project in order to be removed from the repository, that's the whole point. I (and every other user) should be able to control my account's participation in projects as I please. Otherwise this is starting to feel like a jail for my account.

    And whoever had the guts to actually close this issue with so many people STILL reporting the same problem is out of their minds, and actually plain rude.

    I am greatly disappointed.

  14. Radomir Đurđević

    Finally! I went to the team tab, and there it was, the "Leave Team" button (top right corner of the screen in the team section). Atlassian has done it!

    Thanks very much I was finally able to pull my account out of a horrific project!

    Regards

  15. João Saraiva

    Great. Now if they'd do the same for leaving projects to which you're associated via a group (not a Team), that'd be "awesome". It's amazing that this simple bug ( https://bitbucket.org/site/master/issues/10466/removing-myself-from-a-different-users#comment-33888687 ) has been around for at least 8 months (and that's when they acknowledged it), and still no way to solve it... Just how complicated is it to remove a couple of associations between some database rows? If it helps, I would have no problem in removing myself from a group, in order to remove myself from any associated projects.

  16. Jimmy Chau

    Well, it's been years and still no way for me to remove myself from other group's repository. I have dozens of repositories with this group in my account and it is really cluttering it up. It is amazing how they never put in a button to just leave a group.

  17. PrimeLens

    sigh. atlassin get your shit together. this is so annoying. i need to stare at repos in my list that i dont want in my list and no way to prevent them appearing in my list.

  18. Alastair Wilkes staff

    Hi y'all,

    The revoke button on the repository overview page or leave team button on the team profile should cover most cases. However, if you have access via a group and don't want to leave the team (or if the group is owned by an individual account), there's no recourse - so we recently reopened #454 to cover these cases.

    In the meantime, if the revoke button on the repository overview page or leave team button on the team profile page doesn't show up for you, contact support, and we'll help get you sorted.

    Thanks,
    Alastair

  19. Barnabas Nanna

    Please this should have been implemented. As a contractor, you get added to different company projects. I believe it makes sense to remove oneself when you leave the company

  20. Marlo Vlietstra

    Just lost me as a user and sent me to GitLab due to this issue.

    I was invited to a private repo of a user and am not part of any team for the project. I can not remove this dangling repo that I do not want to be a part of.

    curl did not work for me.

  21. juliolt

    Omg, so random that this is still happening. As some other users mention before, it should be a MUST that a given user decide if he/she stays in one repository. Owner should invite/permit. I should not ask for any permission to anyone.

    How ridiculous is to ask to someone else, hey, could you please remove me from your repo?

    Hilarious

  22. Samuel Ryc

    Please fix this, someone? I love Bitbucket and would love to continue using it... But this is just a pain to see all those projects I don't belong in anymore still in my feed...

  23. Simon Hughes

    The button is there; On the repository overview page, you should see below the SSH link.

    Last updated: 19 hours ago
    Language: PHP
    Access level: Read  (revoke)
    

    The "revoke" button will ask for confirmation, then remove you from the repository.

  24. Marlo Vlietstra

    Thank you Simon Hughes!

    Longer instructions for others: Click on avatar -> Bitbucket settings -> Integration and features -> Labs -> Disable "New source browser experience" -> Go to repository overview page -> Click on "(revoke)".

  25. Anonymous

    omfg. In new design there's no button yet. U wasted so much time of mine, bitbucket. GL. Moving to gitlab

  26. MariaL

    I am trying to remove myself from an old repository which is EMPTY in the meanwhile!

    So there is a different "Overview" text in the repository and of course no "Revoke" button, although I have already disabled the "New source browser experience"

    Why is this so hard to fix Atlassian?????

  27. Vahe Harutyunyan

    I do not see "Overview". I think it should be very simple, I cannot understand why you are not making it easy. This is very basic functionality which I should find in UI and not start googling.

  28. eriksteinmetzataugsburg

    It now appears that even under the old browser experience the option to remove oneself from someone else's repo is not present. Has anyone else noticed this?

    Going directly to the https://bitbucket.org/<myname>/<reponame>/overview/ address seems to bring up a 404 error now.

    It does appear that this issue has been fixed in the new browser experience, under issue 454:

    https://bitbucket.org/site/master/issues/454/ability-to-remove-yourself-from

    Basically in the ... button (pop up menu) just to the right of the clone button, the bottom menu item will be "Leave repository".

  29. Log in to comment