Failing while Pushing the code using Android Studio to BitBucket

Issue #11741 invalid
Arindam Mukherjee created an issue

I am trying to push the code to my Bitbucket repository using Git from the Android Studio.

I have created a repository and added the ssh key there. Now I have tried the below command from the git bash:

ssh -T git@bitbucket.org

I got the output like below:

authenticated via a deploy key.

You can use git or hg to connect to Bitbucket. Shell access is disabled.

This deploy key has read access to the following repositories:

abc/xyz: ssss25555sdvvd -- arindam.xxxxx@gmail.com

Now when I am trying to push from Android Studio, it is saying:

Push failed: Failed with error: fatal: Could not read from remote repository.

When I tried with push using the below command from terminal of Android Studio, I am facing this problem:

git push origin master

Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I am not understanding what else I need to do to push the code. Can anyone help me on this please.

Comments (3)

  1. Gary Sackett staff

    Hi Arindam, That error is pointing to an issue with your SSH configuration. If you could please open a suport ticket at support.atlassian.com, our support team can assist further. Cheers,

    Gary

  2. Log in to comment