Cannot push code to repo - [remote rejected] master -> master (pre-receive hook declined)

Issue #12868 resolved
Daniel Tony
created an issue

I have already tried pulling and rebasing but no luck there. What is going on?

Comments (7)

  1. Manpreet Singh

    Sample message with more detail

    Counting objects: 13, done.
    Delta compression using up to 8 threads.
    Compressing objects: 100% (12/12), done.
    Writing objects: 100% (13/13), 4.15 KiB | 0 bytes/s, done.
    Total 13 (delta 8), reused 0 (delta 0)
    remote: canceling statement due to conflict with recovery
    remote: LINE 1: ...er"."date_joined" FROM "bb_repository" INNER JOIN "auth_user...
    remote:                                                              ^
    remote: DETAIL:  User was holding a relation lock for too long.
    remote:
    To git@bitbucket.org:xyz/abcd.git
     ! [remote rejected] master -> master (pre-receive hook declined)
    error: failed to push some refs to 'git@bitbucket.org:xyz/abcd.git'
    
  2. Widjet

    This affects pushing through the web interface too (gives an error 500 internal server error), and applies to all of the bitbucket repositories that I've tried.

  3. Log in to comment