Intermittent SSH errors - 'Connection closed by 104.192.143.1' (BBCDEV-1775)

Issue #13032 resolved
Theodora Boudale staff created an issue

Some users have reported issues when cloning/pulling/pushing via SSH.

These operations sometimes fail with error:

'Connection closed by 104.192.143.1' or

'Connection to git@bitbucket.org:22 exited: Remote closed the connection fatal: Could not read from remote repository.'

We are currently investigating this as a bug.

Comments (19)

  1. Christoph Federwisch

    Also, the proposed solution of setting

    Host *
        ServerAliveInterval 30
    

    in ~/.ssh/config is not working.

  2. Olivier Duchateau

    I'm experiencing the same issue with Mercurial repository.

    When I try:

    ssh -vT hg@bitbucket.org
    

    I get this:

    OpenSSH_6.6.1, OpenSSL 0.9.8zh-freebsd 3 Dec 2015
    debug1: Reading configuration data /home/olivier/.ssh/config
    debug1: /home/olivier/.ssh/config line 1: Applying options for bitbucket.org
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: /etc/ssh/ssh_config line 21: Applying options for *
    debug1: Connecting to bitbucket.org [104.192.143.1] port 22.
    debug1: Connection established.
    debug1: identity file /home/olivier/.ssh/id_rsa type 1
    debug1: identity file /home/olivier/.ssh/id_rsa-cert type -1
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_6.6.1_hpn13v11 FreeBSD-20140420
    debug1: Remote protocol version 2.0, remote software version conker_1.0.207.b177603
    debug1: no match: conker_1.0.207.b177603
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-ctr hmac-sha1 none
    debug1: kex: client->server aes128-ctr hmac-sha1 none
    debug1: sending SSH2_MSG_KEX_ECDH_INIT
    debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
    debug1: Server host key: RSA 97:8c:1b:f2:6f:14:6b:5c:3b:ec:aa:46:46:74:7c:40
    debug1: Host 'bitbucket.org' is known and matches the RSA host key.
    debug1: Found key in /home/olivier/.ssh/known_hosts:11
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey
    debug1: Next authentication method: publickey
    debug1: Offering RSA public key: /home/olivier/.ssh/id_rsa
    debug1: Server accepts key: pkalg ssh-rsa blen 279
    debug1: key_parse_private2: missing begin marker
    debug1: key_parse_private_pem: PEM_read_PrivateKey failed
    debug1: read PEM private key done: type <unknown>
    Enter passphrase for key '/home/olivier/.ssh/id_rsa': 
    debug1: key_parse_private2: missing begin marker
    debug1: read PEM private key done: type RSA
    Connection closed by 104.192.143.1
    
  3. Gary Sackett staff

    Hi Everyone, We have made some changes this morning that should solve some of your issues, and help us troubleshoot others. Could you run a few more tests, confirm if the issue is resolved or not for you, and if not provide some debug for us?

  4. Log in to comment