Clicking the "<>" code button while composing comment on an issue scrolls the page and does not insert code tags

Issue #13453 open
Robert Leach
created an issue

Running Safari on Mavericks.

BUG 1:

I noticed that lately, the code button doesn't seem to work in certain circumstances, which I have worked out to be:

  1. When text in the text area takes up more lines than are visible
  2. Then the page is not scrolled to the bottom

If both of those cases are true, the code button does not insert the code wrapping tags and scrolls the page to the bottom.

Bug 2:

Clicking cancel when asked what type of code tags to insert, inserts the tags anyway.

I have created a screen recording of these behaviors:

https://dl.dropboxusercontent.com/u/87939936/BUGS/bb-code-button-bugs.mov

Comments (7)

  1. Sean Farley

    I tried this on macOS and El Capitan but wasn't able to reproduce this. Unfortunately, we don't officially support Safari 9 since Apple makes that so hard to do (and warns against it).

  2. Zachary Davis
    • marked as trivial
    • removed assignee

    I had a look into this. I can reproduce "Bug 1" (page scrolling) on several browsers, but only if the cursor in the comment box is scrolled entirely off of the viewport. I was unable to quickly figure out what is causing that (the underlying code for that feature is not obviously trying to reset the scroll position of the page).

    I am still completely unable to reproduce "Bug 2" (insertion on cancel) in any browser's current version.

    Due to the very specific nature of Bug 1, and the fact that it works fine once the cursor is in the viewport, I'm not planning to spend any more time on this right now.

  3. Log in to comment