Cannot change to a specific branch when viewing a directory (BBCDEV-7853)

Issue #14160 open
Mikel Iglesias created an issue

When viewing a directory of a repo in the Source view, there is one branch B that when selecting it, it will change to the branch A instead. A teammate also tried this and could reproduce the same issue. We tried in 2 different repos and in both there is a branch that when selecting it, the view won't change to that branch, it will change to a different branch. This won't happen when viewing a file, only when viewing a directory. If I open a file in the Source view, and change from master to branch B, it will change to B; but doing this in a directory, it will change to A. It only happens with one specific branch. In one repo, we have 6 branches and it there is only one that presents this behaviour. In another repo, we have 3 branches and only happens with one of them.

To reproduce this issue, I just select master, then select the branch B and it will change to branch A.

Comments (3)

  1. Daniel Tao staff
    • changed status to open

    I am able to reproduce this in some cases. It seems that for the most part (at least in my testing), the right branch is selected; but in certain cases the same wrong branch is consistently selected.

  2. Log in to comment