distribute-setup.py does not work with Python 3.1.1

Issue #1523 invalid
Anonymous created an issue

Hi there,

I just tried distribute-setup.py with python 3.1.1 and I get the following traceback:


File "distribute_setup.py", line 140 except pkg_resources.VersionConflict, e: ^ SyntaxError: invalid syntax


I ran 2to3 -w on it and it still failed with the following traceback:


Downloading http://pypi.python.org/packages/source/d/distribute/distribute-0.6.2.tar.gz Extracting in /tmp/tmp3zpdM_ Traceback (most recent call last): File "distribute_setup.py", line 428, in <module> main(sys.argv[1:]) File "distribute_setup.py", line 424, in main _install(tarball) File "distribute_setup.py", line 72, in _install extractall(tar) File "distribute_setup.py", line 404, in extractall directories.sort(sorter) TypeError: must use keyword argument for key function


With the 0.6.2 release supporting Python 3, I thought I should mention issue.

Thanks for the great work! Krys Lawrence krys at krys dot ca

Comments (2)

  1. Anonymous

    Oops, posted the bug report on the wrong place. This was for tarek/Distribute.

    Please disregard.


  2. Log in to comment