An error when mapping volume on Docker

Issue #15444 resolved
Rafal Janicki
created an issue

Per this community question: https://community.atlassian.com/t5/Bitbucket-questions/Bitbucket-pipelines-how-can-I-map-a-volume-to-docker-to-expose/qaq-p/686951#U695654

I'm unable to mount a volume to a Docker build in a BB Pipeline step:

docker: Run command: docker run -v /opt/atlassian/pipelines/agent/build/packer-tmp/packer-docker516303980:/packer-files -d -i -t alpine:3.6 /bin/sh==> 
docker: Error running container: Docker exited with a non-zero exit status.==> 
docker: Stderr: docker: Error response from daemon: authorization denied by plugin pipelines: Command not supported.

The Pipelines' wiki says that the volumes can be mounted, but only in the repository's directory. However, this is what I do here (by using ${BITBUCKET_CLONE_DIR}), but I still get the error.

Comments (2)

  1. Aneita Yang staff

    Hey Rafal,

    I notice on the Community post that you've managed to find a workaround to the problem, so I'll close off this issue. Please feel free reopen this issue if your problem isn't solved.

    Thanks,
    Aneita

  2. Log in to comment