Unstable wiki edit when using cloned repo and online edit

Issue #15660 new
Eric Gagnon
created an issue

Hello,

I report the problem here but I'm not sure if the problem is with Bitbucket Cloud or SourceTree...

I'm still trying to figure out why but I have just done another clone (with sourcetree) and last hour edits are not visibles (before that it was a full month off).

Things where looking fine before but it started to get mixed up when I tried to add image in the repository while editing text via the web.

At some point, the local cloned version started to desynchronized (trying to get master was without effect).

Any idea?

At first I tought it was a conflict because my repos was named something like myrepo-wiki, so the clone is myrepo-wiki/wiki. It was not conclusive but maybe it could be a source of conflict?

Comments (3)

  1. Eric Gagnon reporter

    Had it again. So the basic sequence is:

    • Clone wiki local
    • Add a image commit and push (on master, nothing fancy)
    • Add a link to the wiki using cloud edit. The image is displaying fine.
    • Do some more edit.
    • I check sourcetree and it display a 1 on "send".
    • If I try to send I get :

    error: failed to push some refs to 'https://...something-doc.git/wiki' hint: Updates were rejected because the remote contains work that you do hint: not have locally. This is usually caused by another repository pushing hint: to the same ref. You may want to first integrate the remote changes hint: (e.g., 'git pull ...') before pushing again. hint: See the 'Note about fast-forwards' in 'git push --help' for details.

  2. Log in to comment