When selecting a default branch with a slash ('/') in the name the source browser only shows "Hmm... can't find that one"

Issue #15914 resolved
Thomas Danzl created an issue

I had the following setup:

  • Repository with C# set as language
  • master branch
  • amber/main branch which was branched from master

Works

  • selecting the "master" as the default branch --> I can nicely browse through all the code including the code in "amber/main"

Fails

  • selecting the "amber/main" branch as default branch --> I am not able to brows any code in any branch; I always get "Hmm... can't find that one".
  • But when I go to the branches; select a branch and click on "View Source" on the right top I can see the code.

Seems as the source browser is not happy about the slash '/' in the branch name.

Comments (16)

  1. Amber Van Hecke staff

    This bug was addressed with a release we made in early April. If you continue to have this problem, please open another ticket so we can quickly address any new issues. We appreciate you helping us out by reporting problems you experience.

  2. Thomas Danzl reporter

    My report was not for the installed version of bitbucket; it was for the bitbucket.org cloud version; so I have no option to do any upgrades ;)

    And I am sorry that I did not point that out nicely in the description.

  3. Amber Van Hecke staff

    Thomas, are you still having the issue when using the new source browser on Bitbucket Cloud? (the source browser can be turned on by going to Bitbucket Labs in settings, when you click on your avatar in the lower left corner)

  4. dath(om_codereview)

    hm strange. I know I tried it several times in different ways and I am pretty sure I used the new source browser. But whatever I do I cannot reproduce it anymore.

    So thanks for your patients. It simply seems to work now :)

  5. Amber Van Hecke staff

    For those still having this issue, can you please submit a support ticket and link to this issue and mention my name. I would like to dive into your issue further and hopefully figure out if there is a corner case we aren't capturing.
    Thanks for your help!

    link to support: https://support.atlassian.com/contact/#/

  6. Tyler Tadej staff

    This issue should now be resolved. We will be closing the ticket soon unless others are still having the issue.

  7. Log in to comment