Deploy build artifacts to Bitbucket Downloads broken with Unauthorized 401 status code

Issue #16253 new
Rémi Laurent created an issue

Hi,

so basically the exact issue described here https://bitbucket.org/site/master/issues/13919/deploy-build-artifacts-to-bitbucket and that was silently closed

Documentation followed:

https://confluence.atlassian.com/bitbucket/deploy-build-artifacts-to-bitbucket-downloads-872124574.html

Current setup:

  • member of a team
  • created a repository (team is owner of it, I am "rlaurent-de" also Admin)
  • created an app password for my account "rlaurent-de"
  • unable to use this app password to upload content, always getting a 401 from api.bitbucket.org
  • tried in bitbucket pipelines and also tried with curl from my laptop

Extra info:

End of 2017 I configured two such pipelines and everything was working correctly, I've rerun one of them today (2018/05/08) and the build went fine with old app token generated in 2017

Out of curiosity I only regenerated their app token and redefined env variable of pipeline and now everything is broken with a 401 Unauthorized as described above ... (and I'm absolutely positive those were app token linked to my account, not a team account; I've deleted it and recreated in the same screen then updated the environment variables of the pipeline)

Thanks in advance for the time taken

Comments (1)

  1. Albert Martin

    Experiencing the exact same problem here with team repository and an app password following the documentation you linked. The only thing that worked was using my personal username rather than the team name.

    Less than ideal for sure. Would be nice to have some sort of API key for the entire team that way a deployment step isn't tied to a personal account on the team. But from what I hear these were deprecated in favor of the app passwords.

  2. Log in to comment