Unable to create Access key at repo or user level

Issue #16565 new
Alfonso Fernández created an issue

Is not posible to add a SSH key from either the Repo -> Settings -> Access keys -> Add key nor User -> Settings -> SSH keys.

The loading spinner spins forever but the ssh key is not created.

I've tried in Safari and Chrome.

Thanks.

Comments (7)

  1. Jānis Elmeris

    Same here.

    Error: Syntax error, unrecognized expression: * key
      * That SSH key is invalid.
    jquery.js:1458
    
  2. Alfonso Fernández reporter

    Screen Shot 2018-06-22 at 19.37.59.png

    Yes I found in the developer console that the api returns error 400 when the key is in invalid format or when the it is already used

    but the UI doesn't show any alert or popup, just the spinning loading

  3. Jānis Elmeris

    Oops, I tried to copy my private key there, not the public one.

    Still, an error message should be displayed anyway.

  4. Alfonso Fernández reporter

    Yes, In my case the public key was in wrong format, if anyone has the same problem this could save you some time.

    if you extracted your public key in rsa format with

    openssl rsa -in myPrivateKey.pem -pubout > myPublicKey.pub
    

    You can convert the key to right format with

    ssh-keygen -f myPublicKey.pub -i -mPKCS8 > myPublicKeyFormated.pub
    
  5. Esben Skovenborg (TC)

    I get the same issue, when adding as a new key the content of a ~/.ssh/id_rsa.pub file. I believe this format of a public key has been accepted, without issues, say a few months ago...?

  6. Esben Skovenborg (TC)

    It turned out that, in my case, the problem was I tried to use the same key to access 2 repos on different accounts - which is apparently not allowed. Yes, an error message would have been nice :)

  7. Log in to comment