Markdown: file is not rendering properly

Issue #16607 resolved
Ondřej Seer
created an issue

Hi, I have a problem with rendering .md file. I just copied .md file from GitHub to Bitbucket and it doesn´t work.

readme.md is in attachment.

readme.png

Comments (22)

  1. Ivan Vaccari

    Same problem for me. None of my repos display rendered markdown. Multiple reloads can rarely display the proper html render.

    Here an example of the default angular generated readme.md

    angular2.PNG

  2. Torben Hein

    I am hitting the same problem - multiple reloads eventually lead to a properly rendered md file. Tested with Chrome and FF on Mac

    Have had this issue for at least two months now..

  3. Thomas Schuller

    I made a quite funny experience, in my case the problem turned out to be as follows...

    It was just a problem with cache/cookies. I saw in the inspector of my browser that a request for the rendered version of the readme was sent, but returned with the answer, that it is already rendered. (Which it of course was not...)

    I deleted all cookies, cache and session data for the site in my inspector and after refreshing it worked! (Guess that not the browser cache, but a cookie was responsible, because I had the same prob in different browsers...)

  4. Pavel Řezníček

    Yeah! Bingo, deleting cookies and cache solved it for me too.

    But it’s still not obvious so Bitbucket has something yet to carry for. First, the page shouldn’t trust the “rendered” cookie.

  5. Eddy De Greef

    I don't see any "rendered" cookie. Also, clearing cookies and cache doesn't have any effect for me at all (except that I have to log in again).

    What I see, is that a GET request is sent to the server to render the README.md. The answer (which arrives after more than 2 seconds) contains a structure containing the "raw" and "html" fields, but both contain the raw MD, ie. the html field does not contain any html at all. So it seems to be a server side issue.

    I have the "New source browser experience" still enabled, BTW. When I disable it, the README is rendered correctly.

  6. Log in to comment